Knime 2.9 - Problem with libraries in R nodes

I have just upgraded to 2.9 and now none of my R nodes which require libraries work

I get the error there is no package called 'xxxxxx'

This happens either to the old R local nodes and the new R(interactive) nodes. I have checked that the R installation in preferences has these libraries installed.

This has broken some fairly critical workflows for me.

Any thoughts...?

Thanks

Mark

Are you sure the package(s) are installed into your favorite R installation and KNIME > Preferences > R or > R (labs) is pointing to the R.exe or R_HOME for the latter? The KNIME/R nodes will always use the R installation as specified in the perferences.