KNIME 3.0.1 hangs on Fedora 23

After ungrading From Fedora 22 to Fedroa 23,  KNIME appears to hang with the following message at the command prompt.

CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
---Registering Weka Editors---
WARN     pool-1-thread-1 KNIMEApplication$3      Potential deadlock in SWT Display thread detected.
Full thread dump will follow as debug ouput.

I have deleted the .metadata directory within the workspace directory and restarted KNIME 3.0.1 as well as the computer and still observe the same behavior.

I have running been running version 2.12.2 for some time and it does not have any issues on Fedora 23.  I have attached the log file from the metadata directory.


Any insights would be greatly appreciated




I don't see any reason why KNIME shoule be non-responsive in the log file. The potential deadlock isn't one and startup proceeds just normally. What are the exact effects that you are seeing beside the log message?

The user interface is non-responsive. For example,  if I select preferences,  none of the menu options respond. It takes an extremely long time for the node repository to populate (sometimes it never populates). Knime process runs at about 50%.

I have enclosed a screenshots.



I see, this is different from not responding at all (which I anticipated first). So it's reacting but very slow. In this case, if you happen to have a JDK 8 installed on your system, can you execute "jstack <pid of knime>" and send the output? We may see what it's actually doing.

Is your installation or the workspace on a network drive or on a local disk?

The workspace is located on a local disk (LVM/Ext4).  I hhave attached the output form jstack.

The output unfortunately isn't very helpful. I just tells that KNIME is simply waiting for user actions and absolutely nothing is currently executing.

I downloaded version 3.1 without any extensions and now I get a node list but the UI is just not responsive. Here are some observations:

Selecting any option under preferences does not show the corresponding dialogue and the Java process associated with KNIME runs continuously at 50% however, minizing and restoring the window or dialogue updates and synchronizes its contents with the selected option.  This includes the node repository, preferences and node descriptions.

It appears that this could be an issue with SWT.  I still get the SWT deadlock message (3.x.x series only)

I also have version 2.12.2. with all extensions and  that version runs fine. No deadlock, responsive UI, etc.

Some additional information I am run both 3.1 and 2.12.2 under KDE Plasma 5.

Aha, the resizing hint was important. This is an issue with GTK3 on some systems. You can try starting with the encvironment variable SWT_GTK3=0 or with


in the knime.ini file (two lines at the very top).

Yes,  that's it.  Added the 2 lines to the top of the ini file and now everything is working.  I will continue testing and let you know if I run into any additional issues.

I really appreciate your help with this.  KNIME is my favorite tool for data analysis.  Keep up the good work on a great product.

Again,  thanks for your help.



The same for me [Ubuntu 16.04 x64/KNIME full 3.1.1]: just after running the executable I get

WARN      pool-1-thread-1 KNIMEApplication$3     Potential deadlock in SWT Display thread detected. Full thread dump will follow as debug ouput

and nothing works(clicking on example workflow does nothing, node repository is empty, etc). Setting launcher GTK version to 2 helps.