KNIME 3.1 BUG: Outline view showing blank

Dear KNIMErs,

First off, happy 2016!

So I've got this really huge workflow started sometime back in version 1.4 or so, and it always migrated to new KNIME  versions without a problem - until 3.0/3.1. Now the workflow outline view shows up completely white, with only the boundaries and the main viewport rectangle working as expected. Needless to say that this is of course not quite enough to adequately navigate a massive workflow.

Please try to fix this with some urgency, as it's a real showstopper!

Many thanks,

bump :)

This is very likely a bug in the new Eclipse version. It only happens if you have negative coordinates for your workflow, i.e. when you have moved nodes to the left of the visible area.

Hi Thorsten,

Yes, I do this a lot... Thanks for the confirmation, hoping for a speedy fix Eclipse-side, then.


Hi guys,

Same problem here. I was not aware of the fact the problem appears only if you have negative coordinates in the workflow. Thanks to Thor for this info. So for now the workaround consists in simply moving the whole workflows toward the right side.



Hi guys,

I'm coming back to this issue because sometimes the outline view, a part from being shown blank (this issue can be solved shifting the workflow toward the right, as suggested by Thor) it is wrong. This means that it shown like doubled and the square highlight position in the outline view does not correspond to the real position in the default workflow view. Are these problems related? I hope this can be solved soon as it is really annoying when large workflows are used.



Thanks Gio,

I echo your annoyance… :slight_smile: