KNIME 3.5 on MacOS requires Java 1.6?

Hello everyone,

we were using KNIME successfully on a MacOS with java 8.

While updating to KNIME 3.5, KNIME required a java downgrade to version 1.6. This causes numerous issues, e.g. ant cannot be installed etc.

Is there any reason for this required version downgrade and what can we do to run KNIME 3.5 with a more recent java version (e.g. 8)?




KNIME is actually using a built-in 1.8 JRE (this JRE is shipped within the .app bundle)

At which point during updating were you asked to "downgrade to version 1.6"? It didn't happen to me.



the update was not done from an existing KNIME version, but using the official installer:


The request to install java 1.6 occured in the very beginning of the installation.

We are also discussing this issue in OpenMS gitter at the moment:


Any updates would be highly appreciated.






just for completeness (I also posted this in gitter):

Can you try to manipulate the knime.ini as follows:

Default in the Knime.ini there is an argument -vm ../Eclipse/plugins/org.knime.binary.jre.macosx.x86_64_1.8.0.152-01/jre/Home/bin

change that to

-vm ../Eclipse/plugins/org.knime.binary.jre.macosx.x86_64_1.8.0.152-01/jre/Home/lib/jli/libjli.dylib

Please let us know if this worked. Sorry for the trouble,



I faced the same problem and it looks like changes to knime.ini did the trick for me. Now I can launch 3.5.0 application.

The problem is I have installed 3.5.0 using manually downloaded files and now two separate setups exist on my disc. I would prefer to keep only one installation, just upgrade my old 3.4.1 setup instead of downloading all extensions for the new 3.5.0 environment. 

Unfortunately there is no such option available, upgrade in file menu displays message that there is no new version available...

Any idea how to sort it out?