KNIME 3.6.0 error: "Selected Keras back end 'Keras (TensorFlow)' is not available anymore"

I cannot find a “KNIME Deep Learning - Python Backend” extension neither as binary or source version. I made two screenshots of the available and installed extensions…


By the way, do the extensions have a “dependency system” like apt/dpkg on Linux so that warnings and suggestions apear just in case?

The “KNIME Deep Learning - Python Backend” extension cannot be installed on its own but is implicitly installed when installing the Keras extension. You can verify that it’s there via Help > About KNIME Analytics Platform > Installation Details > Plug-ins. It should be present in the list (column Plug-in Name).
Yes, there is a dependency system that makes sure that all dependencies of an extension are properly resolved (see above).

It is there…
But I gave up making in run under Windows. Now I use Linux (with anaconda environment) which I prefer anyway.

1 Like

Hi spider,

we are currently trying to tackle this issue but have problems reproducing it. Which version of Windows did you use?

Thank you!

Hi Benjamin,

it Windows 10 (LTSB so “old” 1607).

Alright, thank you for your reply!
Maybe this will help us in to track down the issue.

@spider we’ve just pushed a fix on our nightly build (which should be available tomorrow morning). Would you mind quickly testing if our fix resolves your problem on your windows machine? We can’t really reproduce the problem locally.

Thank you!

1 Like


I tried “knime_3.7.0_2018-08-20_12-01-35” and now it does work :grinning:


That’s fantastic. Thanks for trying… this was really a tough one :slight_smile: The fix will be part of our 3.6.1. release.

Sorry for the trouble, let us know if we can help with anything else.


Hey there,

i faced the same problem using python in knime.

is there any timeline for the 3.6.1 release?

if not is it somehow possible to maybe an older version of the required plugins from an old knime zip archive?



Hi Andreas,

KNIME 3.6.1 will be released soon. I can’t specify a more precise timeline, unfortunately.
Older versions of the plugins should be affected by the same bug, I don’t think changing back to them would help. In general, you can get old KNIME downloads and update sites here:


Hi Marcel,

thanks for the info. i tried to take an old zipped version but Knime won’t allow me to install older versions of the plugins. i guess waiting will then be the only option, as i don’t want to do a complete re-installation.

btw the error massage I get is the following:

Traceback (most recent call last):
File “C:\Program Files\KNIME\plugins\org.knime.python2_3.6.0.v201807061638\py\”, line 278, in execute
exec(source_code, self._exec_env, self._exec_env)



Thanks :slight_smile:
So, what was the cause of this “bug”. Is it Windows 10 LTSB?

Andreas, the error message you get could actually be caused by something different. Would you mind uploading your knime.log file? Thanks!

We’re actually not entirely sure why this error only happened on windows, but it was a race-condition in our python plugin initialization.

I’m sorry but I de-installed the 3.6 and re-installed the 3.5.3 in order to have a working version again. needed a solution for work, sorry about that. the 3.5.3 version works fine so far including the python implementation.

FYI: KNIME 3.6.1 was released today. We’ll highly appreciate any feedback :slight_smile:.


thanks for the info!

1 Like

It does work now as expected, so use KNIME 3.6.1. Thanks for debugging :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.