knime 4.2 linux java errors

After an update (new install) to KNIME 4.2.0 for linux, when I start KNIME, I get multiple java-related errors in the console and the launching terminal. For example, see below:

ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.RuleEngineVariableNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.twoports.RuleEngineVariable2PortsNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.preproc.stringmanipulation.StringManipulationNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.preproc.stringmanipulation.multicolumn.MultiColumnStringManipulationNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.RuleEngineNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.RuleEngineFilterNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.RuleEngineSplitterNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.twoports.RuleEngine2PortsNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.twoports.RuleEngineFilter2PortsNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.twoports.RuleEngineSplitter2PortsNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.pmml.PMMLRuleEditorNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.pmml.PMMLRuleSetPredictorNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.totable.RulesToTableNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.rules.engine.decisiontree.FromDecisionTreeNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!
ERROR RepositoryManager Node ‘org.knime.base.node.preproc.stringmanipulation.variable.StringManipulationVariableNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created. The corresponding plugin bundle could not be activated!

Hi @rjrich,

can you please set your log settings to DEBUG, restart KNIME AP and then send us the log file? It seems there are some issues with your installation, but we need more information to figure this out.

best,
Gabriel

Thanks for replying. Please find attached my log file that was generated per your instructions.

– Rudy
knime.log (157.1 KB)

Hi @rjrich

It seems like something is wrong with that AP installation, can you try with a freshly downloaded one and a different workspace?

best,
Gabriel

Hi Gabriel,

I had already tried reinstalling, but I will try it again, making sure to use a freshly downloaded installer file.

–rjrich

1 Like

Gabriel,

Please find attached my log file in debug mode after reinstalling KNIME. The only things I did differently this time were as follows:

  1. Did not rename knime folder to just “knime”.

  2. Did not have the knime-workspace folder placed inside the knime folder.

  3. Did not install as many extensions.

Please let me know if the log file now looks normal or if there are any issues.

Thank you.

Best regards,

rjrich

rjrich2.log (37.0 KB)

That logfile looks normal now, are you still experiencing the issues? If yes you need to re-enable debug logging.

Also, if the problem is persisting can you tell us which linux version you are using?

best,
Gabriel

Hi Gabriel,

Thanks for your assessment of the log file. The previous issue has not yet returned. I think (but do not yet know) that the former problem might have been related to one or more of the extensions that I had previously installed but did not install this time. If I add these extensions in the future, I will look for any errors that appear and get in touch again.

FYI, my Linux version is Linux Mint 20 64-bit Xfce, which is based on Ubuntu 20.04 LTS 64-bit.

Thanks.

Best regards,

rjrich

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.