knime 4.2 parallel chunk start missing

Fresh install of knime 4.2 on Windows 10, now parallel chunk start missing?

Knime offers to install missing extension, but nothing gets installed. Error is ‘already installed’.

Any ideas for a fix?

Weird. That node should be present in the installation (and it is in mine).

Does it help to start KNIME via commandline and passing -clean as additional argument?

I also do not have it. Not in 4.1.3 nor 4.2 on Wind 10.

… and -clean did not help?

There is nothing to clean. It is just new installation.

Well -clean actually worked for me, whilst it was a fresh install, I re-used the old workspace, so perhaps that’s the reason it worked?


Yes, there is something weird going on in the workspace. Eclipse/KNIME remembers dependencies between different extensions in some special place (the ‘configuration area’). That’s usually in the installation folder but can also be somewhere else (usually $HOME/.eclipse) in case the installation folder itself is not writable (e.g. installed with admin privileges but running as normal user).

Thanks for confirming. Hope this also fixes the issue for @izaychik63.

For me it is not working not 4.2 nor 4.1.3.

Did you also try it with -clean?

Yes. I try to add it to ini file and as knime.exe -clean without luck.

Knime virtual nodes needs to be installed to have it. It is not installed by default.


Yes, true. That’s the extension containing the parallel chunk nodes. The name is … suboptimal… I’m going to change the name of the extension so that it better reflects what it contains.