KNIME 4.5 freezes for loop

Hello KNIME community,
Did someone else experiences KNIME 4.5 freezing because of an " Unhandled event loop exception"? I tried everything I could to avoid it but it seems out of my hands. The error:
!MESSAGE Unhandled event loop exception
at org.knime.workbench.explorer.view.actions.export.WorkflowExportWizard.addPages(
at org.eclipse.jface.wizard.WizardDialog.createContents(
at org.eclipse.jface.window.Window.create(
at org.eclipse.jface.dialogs.Dialog.create(
at org.knime.workbench.explorer.view.actions.export.WorkflowExportHelper.openExportWizard(
at org.eclipse.jface.action.Action.runWithEvent(
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
at org.eclipse.jface.action.ActionContributionItem.lambda$4(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Display.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
at org.eclipse.ui.internal.Workbench.lambda$3(
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.knime.product.rcp.KNIMEApplication.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(
Thanks in advance for any help :slight_smile:

Hi Silvia,

thanks for including the KNIME version and even grabbing logs with your request. :slight_smile:

The unhandled event loop may be a byproduct of the underlying issue, and it is hard to investigate without being able to reliably reproduce the issue (e.g. by executing a specific example workflow).

However, an always applicable suggestion is updating :slight_smile:
If you’re not limited by company requirements (missing installation rights, older server environment, …), would an update to KNIME 4.7 be an option?
Even if you need (or want) to stay on 4.5, you may be able to use the .zip download of version 4.7 (which can be extracted anywhere and doesn’t need to be installed) as a secondary setup to test whether the issue comes up there as well.
Sorry I don’t have a more concrete suggestion at hand. Maybe others do and can chime in. :slight_smile:

Kind regards


Hi Marvin,
thank you very much for the reply and sorry for the delay! Sadly I am limited by company requirements (compatibility with the version on the KNIME server). I actually tried the same on KNIME 4.7 and it worked, so I guess I’ll continue with that for the moment. Are there some ways to “downgrade” the workflow before uploading it to the server? I guess it is all about the nodes in the workflow right?

Hi Silvia,

thanks for the update. Sounds like a working workaround. :slight_smile:
Maybe a fresh 4.5 install may even resolve the issue, without introducing the need to “downgrade” workflows. On the topic of “downgrading”: in many cases, there is no difference in the workflow compared to it being created in an older version. New nodes will not be known and in rare cases nodes may have new settings that are missing in old versions, preventing their (expected) execution.

What you can do is develop the workflow in the newer version, but before uploading it to the server or a shared repository, open it in an older version, check that it still works and save it again; then upload.

This can be done by exporting and importing the workflow, or by having both KNIME versions use the same workspace folder (though then only one KNIME instance can be running at a time).

Kind regards


Thank you so much for the detailed answer!

You are most welcome :slight_smile:

I’d give the fresh 4.5 version a try first (fingers crossed that it solves the issue :crossed_fingers:), but if you do end up using two different versions, note that saving workflows in the older version is important, as that sets the version of the workflow.

Kind regards

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.