Knime 5.1.0 - Repository is empty in Modern UI and workflow from Knime 4 does not open in new interface

Dear Knime Support,

I am writing to report two issues that I am experiencing with Knime 5.1.0.

First, the Repository area is empty in the Modern UI interface. There are no nodes visible and searchable. I have tried reinstalling Knime and Modern UI extension several times, but the problem persists.

Second, workflows created in Knime 4 do not open in the Modern UI interface.

I have tried reinstalling Knime several times, but the issue has not been resolved.

I would appreciate any help you can provide in resolving these issues.

Thank you for your time and attention to this matter.


what if you switch to classical UI. Does anything work there for you. Also note that double click a workflow if KNIME is not already open currently does not open the workflow in KNIME 5.

Thank you very much for your prompt response.

  1. I am working in the classical UI. There’s no issue, except that I receive the warning message “Missing node (SINGLE) can’t be displayed” and “No further information available. Please check the configuration of the workflow” in the Column Filter node dialog window. (See Picture 1)
  2. When the classical UI is active, I can open a workflow by double-clicking. However, in the Modern UI, this is not possible.
  3. In the Modern UI, I can create a new workflow, but the nodes in the repository are missing. (See Picture 2)
    Thank you

When the instruction here is tried, the problem is solved.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.