KNIME AWS Instance GPU Deep Learning Setup


I am trying to set up the KNIME AWS Instance with the Deep Learning GPU option but I am getting the errors in the screen shot here. Has anyone seen this before or have a solution to it?


I should have added some more context to the problem. Basically I’ve created an EC2 market place instance of the KNIME desktop using a P2.large choice which has a GPU. When I go into try to run the basic cats and dogs keras examples I’m running into this issue.



Hi @brendanPdoherty,

there seems to be some problem with your Python environment. How did you create the ‘py3_knime_deep_learning_GPU’ environment? Anyway, you could try to create a new one using the ‘New environment…’ button. Also, could you post the full error here?


1 Like

I just created it using the New Environment button within the Deep Learning section of KNIME (not sure if this can be recreated inside an AWS EC2 p2.large instance). Below is a screen shot of the full error.


The image suggests that you were able to successfully install the environment, correct?

The shown error seems to be some dependency issue with Tensorflow and your GPU (CUDA) setup. To summarize, Tensorflow with GPU needs some specific CUDA software to be installed in order to be able to work properly. Usually, the CUDA setup is taken care of by Anaconda, however I could imagine that if you have some CUDA software already installed on your machine, there are some conflicting dependencies. I found this issue on Tensorflow where people report the same issue: On which machine exactly are you trying to configure KNIME Deep Learning at the moment? Is it your local machine? Did you previously install and CUDA software on it?

1 Like

This is an EC2 instance of KNIME from the AWS market place (p2.large) which comes with a GPU. This is why I thought there would be no issues in setting up the GPU environment on it.

Looks to have been an NVIDIA Driver config issue. Resolved now.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.