Knime Batch Execution

Hi there.

I'm trying to run a simple workflow in command line using this command:

C:/Users/dri/Downloads/knime_2.7.0/knime.exe –nosplash –noexit –consoleLog –reset –nosave -workflowDir="C:/Users/dri/Documents/AHO/AHO KPI's/Yellow_Fever_Testing_Batch_Execution“ -credential=credential_name;user;pass1 -credential=credential_name;user;pass2 -preferences="C:/Users/dri/Downloads/knime_2.7.0/preferences.epf" 

This workflow have two database connections, that's why I'm passing the credentials.

The problem is that when I try tu run it, a window of KNIME Desktop opens and ask me for the workspace and for the credentials (that I already put in my commnad)

I try to run a simple workflow without any DB connections but the result is always the same.


Can somebody help me with this? Is there something wrong with my DOS command?


Thanks in advance.


Joana Dias


Hi Joana, yes it sounds like the command is wrong, please double-check the options:

Hi and thanks for the response. I already had checked this FAQ, however I'm still with problems running this.

I tried the follow (in one line):

C:/Users/dri/Downloads/knime_2.7.0/knime.exe –nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir="C:/Users/dri/Documents/AHO/AHO KPI's/Yellow_Fever_Testing_Batch_Execution“ 

And I get exit code 2.

If I try to reorder the parameters like:

C:/Users/dri/Downloads/knime_2.7.0/knime.exe –nosplash  -workflowDir="C:/Users/dri/Documents/AHO/AHO KPI's/Yellow_Fever_Testing_Batch_Execution“ -application org.knime.product.KNIME_BATCH_APPLICATION

I had the same problem: KNIME Desktop will open and ask for the workspace.

This is for a no DB connections workflow. If I try my examples with DB connections, maybe the problem is in credentials parameter. I can't find any example of that in the forum. I folow the instructions by the ppt of the KNIME Training Course:

(Windows, in a DOS window):

knime.exe –nosplash –noexit –consoleLog –reset –nosave -workflowDir="C:/Users/rosy/knime_2.5.1/Course_workspace/IntroductoryCourseDay2/database“



–application org.knime.product.KNIME_BATCH_APPLICATION 


......but it's not working.


Thanks !

It looks like that the dashes "-" are wrong. It need to be a single "-" not a "–" (auto-creating long dash); can you please check. The credential option looks correct: -credential=RS;knime_user;knime_user, that is, ID, user name, and user pw.


Hi there.
At the moment I'm passing this on the command line:
C:/Users/dri/Downloads/knime_2.7.0/knime.exe -nosplash -noexit -consoleLog -reset -nosave -workflowDir="C:/Users/dri/Documents/AHO/AHO KPI's/Yellow_Fever_Batch_execution"
You were right about the dashes and that's already solved. However the problem persists.
Im testing a workflow without credentials, so it shoud be more simple...


You haven't specified the application that should be started (-application org.knime.product.KNIME_BATCH_APPLICATION).

It's working fine !

Thanks for your help =)