Knime Batch Mode

Hello,

i have been using the KNIME Batch execution under KNIME 2.0.0 using the following. This has been running successfully:

C:\Users\k\knime_2.0.0\knime.exe -nosplash -consoleLog -noexit -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\Users\k\Documents\workspaces\workspace - knime 2.0\DTFS”

After switching the knime 2.0.3, the above gives a message:

WARN R Snippet (Local) R Binary not specified.
WARN R Snippet (Local) R Binary not specified.
Workflow Manager 0:2: IDLE (start)
Data Generator 0:2:2 (CONFIGURED)*
R Snippet (Local) 0:2:19 (IDLE)
R Snippet (Local) 0:2:44 (IDLE)
R Snippet (Local) 0:2:100 (IDLE)
Workflow Manager 0:2(end)

WARN R Snippet (Local) R Binary not specified.
Finished in 0 secs (606ms)
Running the stream manually works successfully.
Could it be that the usage of the batch mode changed?

Thanks your help,

Kai

1 Like

Can you try it with an additional argument “-data <ws>”, whereby <ws> is the path to the workspace that you usually use? I assume it’s missing the preferences (incl. the global R path).

Thanks
Bernd

Hello,

thanks for the help. As you mentioned, the (R-) preferences seemed to be missing. After trying to apply above and since the error was referring to the R nodes only, the easiest method found to fix it was to set in the R Snipped Node the R path configuration “R binary path” to override with a working R path set. Now it works. I hope this feedback may also help others.

Thanks and best regards,

Kai

Thanks for letting us know. There are actually three methods to “fix” that problem:

  • Overwrite the R path in all nodes as you described
  • Pointing the batch executor to the pre-configured workspace that was used to create the workflow (see my previous comment)
  • With KNIME v2.1: Export the preferences in the Desktop version (File->Export Preferences) and passing this file via the "-preferences=..." argument to the batch executor.
... just for the sake of completeness.

How can I use the bath mode, I can't understand how its used.

Thanks