KNIME - BIRT Integration : Error in plugin Installation

I am exploring BIRT integration with KNIME.

It seems it is possible to integrate Eclipse-BIRT with KNIME as per this FAQ - http://tech.knime.org/node/20598

When trying to install the plugins on my desktop, I got a conflict error with one of the server-side extensions. (KNIME Server RMI Slave).

Cannot complete the install because of a conflicting dependency.
  Software being installed: BIRT Framework 4.3.1.v201308301349-DTDN8fGjtEqcbZz0BQWLW07D_cfT (org.eclipse.birt.feature.group 4.3.1.v201308301349-DTDN8fGjtEqcbZz0BQWLW07D_cfT)
  Software currently installed: KNIME Server RMI Slave 3.8.1.0041140 (com.knime.features.enterprise.slave.feature.group 3.8.1.0041140)
  Only one of the following can be installed at once: 
    BIRT Engine 4.3.1.v201309161141 (org.eclipse.birt.report.engine 4.3.1.v201309161141)

 

It seems we would not face this issue if we would use KNIME Desktop alone.

Could you please help me with this?

 

Thanks

 

Hello, 

It looks like you are trying to install BIRT 4.x (based on eclipse 4) in KNIME (based on eclipse 3).  This isn't currently possible.  The only way to have BIRT tightly coupled with KNIME is via the KNIME Reporting tool, which contains BIRT 3.  You can install this feature from the normal KNIME Update site.