Knime chrashes after upgrading to Ubuntu 14.04


I run Knime in Ubuntu Linux/GNU OS.  After upgrading to Ubuntu 14.04 this weekend, Knime crashes while loading (just before the "loading workbench" bar is complete) every time. 

Any ideas why? 



Following on from my previous post, when I run Knime in terminal, I get the following error messages:

Apr 22, 2014 8:51:14 AM com.knime.enterprise.client.beanlookup.ServerContext createInitialContext

INFO: Created intial context for host on port 47037
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fbb77a272a1, pid=19543, tid=140445879932672
# JRE version: 7.0_07-b10
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.3-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  soup_session_feature_detach+0x11
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /home/wayne/hs_err_pid19543.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.


It seems you are not using the latest version of KNIME. Since Ubuntu 13.10 an incompatible version of Webkit is shipped which leads to crashes in older KNIME version. More recent versions detect this issue and disable any html rendering.

Ok, thanks.  I have deleted Knime 2.8.2 and replaced it with 2.9.2 and it now works in Ubuntu 14.04.

That's a relief!


@wtwine: is your "Node Description" window working properly?

After upgrading to 14.04 I get the error message: "The operating systems web browser could not be found!
Using fall back (text-only) browse" and cannot read the descriptions as before the update.

It also says: "ERROR     BrowserInitializer                 No Xulrunner installation found." in the console.

does anyone have an idea to solve the issue?



big thanks!

installing the extension "KNIME XULRunner binaries for Linux" fixed it for me.

Cannot connect to KNIME server on Ubuntu 14.04 from latest Windows client

I am new to KNIME and not sure of my issue is related. I have set-up the KNIME server and also installed the client-side extention. But I get a time-out  every time I try to mount the server connection. I also set-up the webportal and I succeed to logon  (so that seems to work) but see no workflows. Though I copied some workflows into the server-repository map. In the JVM setting on the glassfish webserver I did add the repository as required.

There must be something I am missing but where to look? Is it related to rights on Unbutu, the fix you describled here, some server side extentions that need to be in place?

For the server I have used the latest  all-in-one package and thus assumed no server-side updates are needed? I also intalled late lates KNIME analytics client (on the server) as that is needed as an engine. 

Overall I find the set-up procedure quite confusing and badly documented considering it is a commercial offering. My hope is with the community. I am happy to share more details if needed.