KNIME component loses mount point link when encapsulating workflow is deployed to Server

#1

I built a simple workflow that uses a component located at LOCAL:/common_components/my_component using “mountpoint link”.

I now deploy to the server my simple workflow at SERVER:/my_folder/my_workflow and the SERVER also has the component at SERVER:/common_components/my_component.

Unfortunately the “mount point link” got lost in the deployment and the my server copy of the workflow contains a copy of the component from my LOCAL workspace instead.

I would expect the server version of the component to be used given the mountpoint link.

any help appreciated

0 Likes

#2

Hello Sebastien,

Thank you for your question. Do you open the workflow as job on the server or as temporary local copy? A double-click on the workflow in the Explorer opens the temporary copy by default, that is also indicated by the yellow bar on top of the workflow. This default behaviour might not be ideal in your case, to open the job on the server you have to right click on the workflow in the Explorer->Open -> as new Job on the Server. This should work then and use the server version of the component.

Hope that helps,
Jeany

0 Likes

#3

I use the server job option which then opens the editor pane with a purple bar at the top. The component has lost its link Icon and if I open it I see the local version of the component and not the server one.

I have reached out to Jeff G. to setup a call this week.

0 Likes

#4

Ok, thank you for the update, that is indeed weird. You are in good hands with Jeff, let me know if there is anything else I can help you with.
Best,
Jeany

0 Likes

#5

so the answer is…

on the server, you need to make sure the update_metanodelinks_on_load is set to “true”…it was set to “false” on my server instance of the AWS AMI.

So go to your knime-server.config file and make sure you have the below entry set to true:

com.knime.server.executor.update_metanodelinks_on_load=true

1 Like