KNIME crashes every few minutes on Windows 10

You shouldn’t do anything about your local Java installation (if you have one) - KNIME ships with its own JRE. Are you doing a specific action each time it crashes (it looks like in this crash you were interacting with a file browser - is this the trigger every time?)

Thanks for the reply. It’s not 100% repeatable I’m afraid. So far I’ve just been playing with a file reader node and some row & column filtering nodes. The crash will happen during different operations, usually a minute or two after I start working with the KNIME UI.

I’ve just been testing for another 10 minutes. A few times, the KNIME UI would crash pretty much as soon as I opened a row or column filter node to configure it. However then it was stable for a few minutes while doing the same operations, and then it just crashed again after around 4 minutes. It doesn’t feel like any specific operation is causing it; more that something is happening in the background that sometimes fails quickly and sometimes takes a while.

Curiously, the last crash log reported a different set of internal exceptions, as well as the original ClassNotFondExceptions - below.

Internal exceptions (10 events):
Event: 16.170 Thread 0x000000000224e800 Exception <a ‘java/lang/NoSuchMethodError’: java.lang.Object.lambda$1(Ljava/lang/Object;)Ljava/lang/Object;> (0x0000000783ada750) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\interpreter\linkResolver.cpp, li
Event: 16.170 Thread 0x000000000224e800 Exception <a ‘java/lang/NoSuchMethodError’: java.lang.Object.lambda$2(Lorg/knime/core/ui/UI;)Ljava/lang/IllegalArgumentException;> (0x0000000783adcd70) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\interprete
Event: 16.847 Thread 0x000000000224e800 Exception <a ‘java/io/FileNotFoundException’> (0x000000076b5deea8) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\prims\jni.cpp, line 709]
Event: 17.003 Thread 0x000000000224e800 Implicit null exception at 0x0000000002c8bd4c to 0x0000000002c8bef9
Event: 17.190 Thread 0x000000000224e800 Implicit null exception at 0x00000000036229df to 0x0000000003622e66
Event: 17.401 Thread 0x000000000224e800 Exception <a ‘java/lang/ClassNotFoundException’: sun/net/www/protocol/about/Handler> (0x000000076e32d470) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\classfile\systemDictionary.cpp, line 210]
Event: 17.408 Thread 0x000000000224e800 Exception <a ‘java/lang/ClassNotFoundException’: sun/net/www/protocol/about/Handler> (0x000000076e352e18) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\classfile\systemDictionary.cpp, line 210]
Event: 17.774 Thread 0x000000000224e800 Exception <a ‘java/lang/ClassNotFoundException’: sun/net/www/protocol/about/Handler> (0x000000076e8d24d8) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\classfile\systemDictionary.cpp, line 210]
Event: 17.780 Thread 0x000000000224e800 Exception <a ‘java/lang/ClassNotFoundException’: sun/net/www/protocol/about/Handler> (0x000000076e8f4590) thrown at [C:\re\workspace\8-2-build-windows-amd64-cygwin\jdk8u152\9742\hotspot\src\share\vm\classfile\systemDictionary.cpp, line 210]
Event: 19.116 Thread 0x000000000224e800 Implicit null exception at 0x0000000003284c9e to 0x0000000003285681

Hi @jkbowser

did you try reinstalling KNIME?

Did you install KNIME using the installer?

Best, Iris

Hi @Iris - Yes that’s the first thing I tried.

I have tried reinstalling with both the KNIME installer and the self-extracting archive, and both versions have the same problem.


I have also tried running KNIME under the Admin account - same problem :\

Hi @Iris I think I may have found the problem :slight_smile:

I read about a similar JRE crash here:

I was using 2 screens attached to my PC, which is the same scenario as the above issue. If I switch to just 1 screen using Windows display settings, the crash doesn’t seem to happen.



This same Java code (as in the related issue) appears in my KNIME error log too:

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j sun.awt.Win32GraphicsDevice.getMaxConfigsImpl(I)I+0
j sun.awt.Win32GraphicsDevice.getMaxConfigs(I)I+10
j sun.awt.Win32GraphicsDevice.getConfigurations()[Ljava/awt/GraphicsConfiguration;+69
j javax.swing.ToolTipManager.getDrawingGC(Ljava/awt/Point;)Ljava/awt/GraphicsConfiguration;+36
j javax.swing.ToolTipManager.showTipWindow()V+115
j javax.swing.ToolTipManager$insideTimerAction.actionPerformed(Ljava/awt/event/ActionEvent;)V+113
J 14474 C1 javax.swing.Timer.fireActionPerformed(Ljava/awt/event/ActionEvent;)V (46 bytes) @ 0x0000000003e4f8a4 [0x0000000003e4f5e0+0x2c4]
J 14472 C1 javax.swing.Timer$ (95 bytes) @ 0x0000000003ae82f4 [0x0000000003ae7700+0xbf4]
J 14578 C2 java.awt.EventQueue$; (5 bytes) @ 0x0000000004111b6c [0x0000000004111860+0x30c]
v ~StubRoutines::call_stub
J 5267;Ljava/security/AccessControlContext;)Ljava/lang/Object; (0 bytes) @ 0x00000000028a2526 [0x00000000028a24c0+0x66]
J 14470 C2 java.awt.EventDispatchThread.pumpOneEventForFilters(I)V (295 bytes) @ 0x000000000482ff38 [0x000000000482f300+0xc38]
j java.awt.EventDispatchThread.pumpEventsForFilter(ILjava/awt/Conditional;Ljava/awt/EventFilter;)V+35
j java.awt.EventDispatchThread.pumpEventsForHierarchy(ILjava/awt/Conditional;Ljava/awt/Component;)V+11
j java.awt.EventDispatchThread.pumpEvents(ILjava/awt/Conditional;)V+4
j java.awt.EventDispatchThread.pumpEvents(Ljava/awt/Conditional;)V+3
v ~StubRoutines::call_stub

Nice find. If you use two screens, does it happen regardless of which screen KNIME is being displayed on?

It seems to just happen on the second screen. It’s also happening less frequently for some reason, once I reconfigured Windows again to extend to a second screen.

Very strange - i’ve heard of wonky behavior from users using Windows on a laptop when plugged into a dock; perhaps this is related… (Thanks again for the sleuthing and reports.)

No problem! BTW, I used KNIME all day yesterday on my first screen… and at one point I opened the output of a Database Reader node into a pop-up window and dragged this onto my second screen. KNIME crashed immediately - so I think it’s definitely related to the second screen somehow.

1 Like

@jkbowser - I had/have the same problem. I had a WIndows 7 machine and it crashed all the time running Knime. My new laptop is a Windows 10 PC and I have not seen it crash while I am using Knime but many times if I leave it alone or come back in the morning it has the blue screen of death. My old machine failed pretty consistently on the Javascript Sunburst Chart… I have the workflow exported but I don’t see a way to upload it. If I can figure out how to upload it I will.

I also use dual monitors and I do a lot of presentations. This issue has been preventing me from showing Knime in public. I hope we can get it resolved.


Hi there @marcc,

welcome to KNIME Community Forum and tnx for your feedback. If you wonder how to upload exported workflow to Forum you can use Drag&Drop or this sign for upload :wink:



MonkeyCo_data.knwf (19.2 KB)

@ipazin - Thanks very much. The file is attached

Hi there,

Just tried it on Windows 7 and works runs just fine. I guess it is to dual monitors…


@ipazin - Based on what @jkbowser said above, I agree. On my last machine it would crash every time I ran it under Windows 7. I could run it under a VMWare LINUX VM on the same machine and it worked fine. The VM only had a single monitor.

I’m not sure how to fix this one…


I’m sure someone will take a look and this will hopefully be resoled.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.