knime crashes when displaying output of RDKit converter

hi folks,
lately, I’ve been encountering this annoying behavior: the node “RDKit from molecule” produces an output but when I try to visualize the output, Knime crashes and leaves the error message pasted below. it seems to me that it is something related to the rendering of the molecule but I am not 100% sure.
I’ve looked for older posts with similar problems but nothing has worked so far: does anyone have a suggestion?

I am running KNIME 3.7.1 on a redhat workstation

any help will be greatly appreciated, thanks


*** Error in `/usr/local/bin/knime_3.6.0//plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/bin/java’: free(): invalid pointer: 0x00007f7a11f6a820 ***
======= Backtrace: =========

1 Like (760 Bytes)
ok, I’ve narrowed down the problem: there seem to be an issue with the conversion of some of the molecules contained in the sd file. I am attaching one of the compounds that makes rdkit (and knime) crash.
I’ve found a workaround: I convert the sd part to canonical smiles using indigo or cdk and then use that with the rdkit nodes. it works now but I can’t understand what causes rdkit to fail so spectacularly while cdk and indigo work fine



same here…I have another post and thought it would be related to the python node which is doing weard stuff…but I figured its really the rdkit molecules.

System: Ubuntu 16.04 LTS
KNIME: 3.7.1
RDKit KNIME integration 3.6.0.v201903281548

Python: Anaconda environment with python 3.6.7 and rdkit 2019.03.1.0 (error was also there for the latest 2018 release, just upgraded today) pyarrow 0.11.0

It was also reported here: Forum post
In the meantime I thought it was solved but might be due to my update on 3.7.1 (was using 3.6.1 before)

I tried to reproduce the rendering crash behavior with KNIME 3.7.2 using the RDKit Nodes 3.6.1 (nightly build) and was not able to crash KNIME - the RDKit renderer worked just fine for the sample molecule you provided. I tested on Windows 7 and Linux RedHat 6.

Maybe the RDKit binaries, version 2018.09.3, that the RDKit Nodes 3.6.1 are based on, contain a fix for your issue, or other KNIME plugins that are used during rendering have been updated. Please retry with the latest build. Just checked in latest changes to the RDKit Nodes, the build should be available on May 14th, 2019.


Thanks for trying it out, unfortunately still the same issue. Crashing with a pointer error as @giovannicianchetta also reported.

Interestingly the Molecule from riccardomartini in the old thread chrashed trying to view the molecule, while the molecule reported here crashed while executing the node.

Tried it with:
Ubuntu 16.06 LTS
KNIME 3.7.2
RDKit 3.6.1.v201905131516

I have attached the error messages for both molecules, but I can send the whole log as well.

rdkiterr.log (3.3 KB)

Sorry to hear that.

I will hand this over to @greglandrum - he knows best about native code issues. There seems to be also some other issues with crashing. I am currently investigating myself about crashes after I got a table with molecules that trigger crashes whenever they are used in KNIME with RDKit.


Hi Manuel,
thanks for taking a look at this!
I doubt it is the rendering alone that causes knime to crash because it happens also with the rkdit from molecule node. it’s pretty interesting because this doesn’t seem to happen with any other rdkit node: I can produce fingerprints, calculate descriptors (and more) directly from smiles or mol fields with no problem at all.
pretty puzzling

I’ve been away from the forum too long. Sorry!

I am not able to reproduce the problem using the test.sdf provided above and an “RDKit From Molecule” node with KNIME 3.7.2 and v3.6.1 of the RDKit nodes on Ubuntu 18.04

Could one of you who is having the problem please share a workflow that demonstrates the crash? It would be great if you exported the workflow with the SDF pre-executed (or save the SDF in the workflow itself).


1 Like

Hi Greg,
thanks for having a look!
it really just occurs is a simple workflow: loading the sdf (sdf reader) and the using the molecule to rdkit node. I am using Ubuntu 16.04 LTS, maybe there is a difference to Ubuntu 18?


I had similar issue on KNIME 3.7. I updated to KNIME 4.0 on Ubuntu 18.04 LTS and the error continues. I’m attaching an example workflow with the SDF imported. The error happens when trying to display the output of RDKit…Example.knwf (129.9 KB)

in my case, upgrading to knime 4.0 has solved the issue: I can now display and convert structures with no problem.

1 Like

Glad to hear that the problem is fixed for you @giovannicianchetta!