Knime crashes when opening a result table reproducably on ubuntu 15.04



unfortunately Knime crashes/hangs on my system reproducably, when I open a result table.

I get the following error message in a shell when knime crashes:

[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
java: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
fixme:advapi:UnregisterTraceGuids 0: stub

Sometimes it does not crash, but stops reacting on any input.

Same for me.


Since the update to Ubuntu 15.04, KNIME (latest stable updates) crashes after opening a data table. Also, the system web browser is not found. I tried on two systems, on both I get the same results.


I've attached my logfile, maybe it helps ;)








Same problem here after updating to Ubuntu 15.04.

KNIME also crashes after opening a line plot.



You should be able to fix the web browser problem by following the FAQ.

I am using Ubuntu 15.04 with GNOME 3.14 and have no crashes when opening tables / views. Maybe it has something to do with the desktop environment?



Thank you Patrick, that solved my browser issue!

I'm running Ubuntu with unity 7.3.2, maybe that's causing the problems... But I'll wait for a fix before changing my system :)






I am also running Ubuntu 15.04 with Unity. I have no browser issues, only opening tables/views/plots (crashes / freezes).

Thanks but the FAQ directions does not solve these issues

You're right "winter", it works well on GNOME on Ubuntu 15.04, fails on Unity

Unfortunately Unity has a long history of breaking other applications. There is hardly anything we can do about it. You may want to try the 2.12 preview and check if the problem persists or if the new Eclipse and/or Java version don't trigger the crash any more.

Hi thor,


I just checked the preview, the behaviour is still the same for me, freeze after opening a data table :(


Since I don't expect this issue to be solved in the next few days, I'll have to give Gnome a try now...


Thank you, cheers




Hi there,

I'm facing the same problem. By now, I could avoid it by using the 32bit version in my 64 bit Ubuntu 15.04 with Unity.

hope it helps,