Knime crashing on Linux 64bit

Dear Knimers,

I experience a lot of crashes of latest Knime (2.5.1) on a Linux Mint 11, katya, Gnome 64-bit. Often when opening a node by double click but also when opening a table view.

Most crashes do not leave an error message and no message in the log or additional files. Sometimes the crash occurs right after restart when opening the first node for configuration. knime crashes with different workflows, I have the feeling more often with larger workflows.

My knime.ini is default with only two changes: -Xmx4096m, -XX:MaxPermSize=512m. I tried a clean reinstall with no plugins, same behaviour. I tried to limit the amount of memory with no effect. I do not experience this with the same workflows on my laptop which runs Ubuntu 32 bit and the 32 bit version of knime so I guess this only occurs in the 64-bit version. I had similar problems before with a 64-bit Ubuntu as well.

On startup I always get the warning message: /usr/share/themes/Felicia/gtk-2.0/gtkrc:79: Murrine configuration option "gradients" is no longer supported and will be ignored. 

Today, I got an error message after a similar crash for the first time, Screenshot attached: 

The program 'KNIME' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 34863 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I then run knime with --sync, however still crashes and does not leave error messages. What can I do?



1 Like

We didn't change anything from 2.4 to 2.5 that may be associated with the problem. Did you make bigger changes on your system?

Thanks for the quick answer.

The system is a fairly fresh installation. I installed it for the main purpose of running Knime on a 64bit system. Knime also crashed in version 2.4 on this system. I installed 2.5 in the hope this was better.

I tried to run Knime on Ubuntu 64bit before, I guess first time with Knime 2.3 and later again with Knime 2.4. This did not work well for me on 64bit (also lots of crashes). So I guess it is not related to the version change.

Thanks, Stephan

We sometimes have similar errors, when we use KNIME remotely via a tunneled X-connection or NX. Does this apply in your case?

No. The crashes happen when using it locally.

Do you have any fancy 3D functionality (compiz) enabled? It works for me if I enable 3D but I wouldn't make that a general statement.

@wiswedel: thanks for that hint. I have used default settings so far but will try to change that. What exactly have you enabled in compiz?

We don't do anything with compiz -- it's just a random guess that this could be the problem. (These problems are very likely in Eclipse/GTK and 3D is just another layer of complexity.)

A post was split to a new topic: KNIME crashes in Ubuntu 18.04