KNIME+eclipse 3.4

Hi all,

I would like to use KNIME with eclipse 3.4. I was able to install it, and also able to use projects created with KNIME 1.3.3 (with eclipse 3.3), but I am unable to create new KNIME projects. The error message says: Invalid project description. Does somebody know what may be the problem? Does KNIME (1.3.5) supports eclipse 3.4?
Thanks, gabor

aborg wrote:
Does KNIME (1.3.5) supports eclipse 3.4?

KNIME 1.3.5 is based on Eclipse 3.2. We do not officially support 3.3 neither 3.4. The later we even haven't tried out ourselves.

Thorsten

It seems that you have not had time to verify this issue, at least it is not in the known issues part of the portal.
For me it is reproducible under eclipse 3.4.x and KNIME 2.0.
Is there an issue tracking system associated with the KNIME project/subprojects?

Dear gabor,

Eclipse 3.4.x is still not officially supported. I gave it a try yesterday and came up with the same problem (it’s missing a project description upon “create new workflow”). The rest seems(!) to work fine (I tested it by importing an existing project.)

I also looked for the cause of the “missing project description” problem and fixed it. It will be included in the next release (though very likely we will not claim that Eclipse 3.4 is supported then … unless we see a true reason for upgrading.)

Regards
Bernd

Dear Bernd,

Thank you for checking and fixing that problem so fast. Usually I like using the most up-to-date (stable) version of the tools, but to tell the truth the update site handling in 3.4 is not the best yet as I experienced, so not supporting officially 3.4 is not a problem for me. I have not done intensive testing regarding 3.4 and KNIME 2.0.0, but I have found only this problem too.
Kind regards, gabor

Hi
Do you have the fix I am producing a documentation/reporting extension proof of concept and it would be nice to be able to create a project rather than import it

Tried to install KNIME 2.0.2 in Eclipse 3.4.2 using the update manager but when trying to install “KNIME & Extensions” I receive the following error message:

Cannot complete the request. See the details.
Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.1.v3449c].

I looked in my Eclipse installation and I have: org.eclipse.swt [3.4.2.v3452b].

Any idea about how I can fix this without reinstalling Eclipse? I suspect this might be something encoded in the update site. Thanks in advance fo the help!

The new Eclipse 3.4 Update Manager is known to behave strange in certain cases, which could be caused by the “old” site.xml files. That is the reason, why we do not support Eclipse 3.4 officially by now. But we are working on it, since e.g. an Eclipse for Vista64 is only available since Eclipse 3.4.

I had only problem with the KNIME Reporting Feature (BIRT). (And maybe previously the binaries for R, R integration, external tools.) So if it is not what you really want, just uncheck it (them) and install all other features.

Thanks for the answers. I was indeed able to install most of KNIME correctly. It seems that as mentionned by aborg, “the KNIME Reporting Feature (BIRT)” causes the error: "Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.1.v3449c]."

The “the binaries for R” are also causing a problem which is different: It requests the “old update manager” Error message: "A feature that you have selected uses install procedures that are not compatible with the current installation support. This feature can only be installed by the older update manager. Do you want to launch the older update manager?"

When clicking launch Eclipse hangs and then the following error message is returned:
"Error creating feature “file:/C:/Program Files/eclipse/features/org.eclipse.datatools.enablement.oda.designer.feature_1.6.1.v200809191145-2118s733I3I6C4_6C/”. [C:\Program Files\eclipse\features\org.eclipse.datatools.enablement.oda.designer.feature_1.6.1.v200809191145-2118s733I3I6C4_6C\feature.xml (The system cannot find the path specified)]
C:\Program Files\eclipse\features\org.eclipse.datatools.enablement.oda.designer.feature_1.6.1.v200809191145-2118s733I3I6C4_6C\feature.xml (The system cannot find the path specified)"

Turns out that after insalling:

  • Datatools enablement oda designer.feature v1.6.2" (which were not included in the KNIME download site)
  • EMF validation Framework OCL Integration (along with all of the EMF features from Ganymede update site/Enabeling Features related to OCL)
  • Ecore OCL search (plus Ecore related dependencies from Ganymed Update site)
  • I was able to install the "R binaries". So only remains "the KNIME Reporting Feature (BIRT)" ! Hope this can help you fix some of these install issues. In addition, I am able to start a new project without needing to import it! Best


    The only problem remaining is to install “the KNIME Reporting Feature (BIRT)” feature which will likely requires allowing to use a later versin of org.eclipse.swt.