KNIME export problem with Java3d

Hi everybody,

I’ve created some KNIME plugins and a feature. I’ve exported my product, and it’s working fine except one plugin. This plugin uses Java3d.
I’ve configured my eclipse, and i’ve added my installer JRE and Java3d to the “Installed JREs” in preferences, and i export this JRE. After i exported the product, all of the necessary j3d files are in the “jre” folder:

But when i open the window what is using j3d, i get an exception:


An unexpected error has been detected by Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x2c6cc964, pid=3740, tid=688

Java VM: Java HotSpot™ Client VM (10.0-b23 mixed mode windows-x86)

Problematic frame:

C [j3dcore-d3d.dll+0x5c964]

If you would like to submit a bug report, please visit:

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

--------------- T H R E A D ---------------

Current thread (0x285abc00): JavaThread “J3D-Renderer-1” [_thread_in_native, id=688, stack(0x2e4a0000,0x2e5a0000)]

siginfo: ExceptionCode=0xc0000005, writing address 0x2c6de7dc

EAX=0x00000076, EBX=0x2cac7876, ECX=0x2e59f5f0, EDX=0x2c6de7dc
ESP=0x2e59f370, EBP=0x2e59f400, ESI=0x2e59f3b4, EDI=0x2c6de701
EIP=0x2c6cc964, EFLAGS=0x00010202

Top of Stack: (sp=0x2e59f370)
0x2e59f370: 2c6ccc38 2c7639c0 2c6de7dc 2cac7840
0x2e59f380: 00000000 00000000 00000000 00000000
0x2e59f390: 00000000 00000000 00000000 00000000
0x2e59f3a0: 00000000 00000000 00000000 00000000
0x2e59f3b0: 00000000 00000000 00000000 00000000
0x2e59f3c0: 00000000 00000000 00000000 00000000
0x2e59f3d0: 00000000 00000000 00000000 00000000
0x2e59f3e0: 00000000 00000000 00000000 00000000

Instructions: (pc=0x2c6cc964)
0x2c6cc954: 40 74 06 83 79 08 00 74 24 ff 49 04 78 0b 8b 11
0x2c6cc964: 88 02 ff 01 0f b6 c0 eb 0c 0f be c0 51 50 e8 d8

Stack: [0x2e4a0000,0x2e5a0000], sp=0x2e59f370, free space=1020k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [j3dcore-d3d.dll+0x5c964]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
v ~BufferBlob::Interpreter
v ~BufferBlob::Interpreter
v ~BufferBlob::Interpreter
v ~BufferBlob::Interpreter
v ~BufferBlob::Interpreter
v ~BufferBlob::StubRoutines (1)

I think, the “j3dcore-d3d.dll” file crashes with the windows, because it wants to write in to the system memory and the windows (exactly the DEP) decect this file as an malicious file (i’m not sure about this). I’ve tried to turn off the DEP, but it’s still not working. I’ve found instuctions, how to install java3d without an .exe installer and i’ve tried everything what i’ve seen there (setting CLASSPATH and PATH environment variable), but it’s still not working.
I’ve tried to use Java3d as an exported feature and i’ve tried to add the necessary files to my plugin (in manifest and extra classpath entry), but it haven’t worked. And now, i haven’t got any idea…
If anyone have an idea, please tell me! :slight_smile: