KNIME freezes when loading workflow with Image Output Widget

Hi,

I am trying to re-open a workflow I created yesterday using the new Image Output Widget of KNIME 4.0. The workflow doesn’t contain an enormous amount of data, it should be fast to load. However, loading gets stuck at the Image Output Widget for an hour or so, and then the loading gets cancelled. (I assume by some internal timer.) I tried restarting Windows 10 but it didn’t help.

Is there some way to manually reset all the nodes in a workflow before opening it with KNIME?
I already tried setting in the settings.xml of the Image Output Widget, but it didn’t help.

Otto

Hi Otto,

that’s a problem that is tricky to debug. For us to understand what went wrong, could you please share with us:

  • what are your memory settings in KNIME (the -Xmx parameter in knime.ini)?
  • would it be possible to share with a some minimal reproducible example workflow? This could have as little setup as possible, while keeping the freeze feature reproducible, and no confidential data included.
  • could you extract and share the thread dump? See https://www.knime.com/faq#q29 for instructions.

A few comments:

  • Could you try this minimal example: https://hub.knime.com/lisovyi/space/forum_16475 . With this i can save and reopen a workflow with the Image Output Widget using my KNIME 4.0 installation on Win10.
  • From the taskmaster screenshot it seems that your machine had RAM almost exhausted. could you try to load your workflow after closing some applications that eat into RAM?

Cheers,
Misha

2 Likes

Hi Misha,

thank you for your answer! I forgot I could export a workflow without opening it, so I reset it, did export&import, and now I’m able to open it. I observe that the problem is not the Image Output Widget, but the OSM Map to Image node just before it. If I set the zoom to 10, the whole workflow freezes when I restart KNIME.

I managed to create a minimal example, which I’ll upload tomorrow.

To answer some of your questions: I use 8090m of RAM, and when I took the screenshot, I only ran KNIME. I guess the rest is Windows…

Thanks for your help!
Otto

1 Like

Hi Misha,

the minimal working example would be trivial: If you set the zoom of the OSM Map to Image node large enough, run the node, close the workflow and re-open it, KNIME freezes. Is there a way to reset the whole KNIME workflow before opening it other than exporting and importing it?

Thanks,
Otto

1 Like

Hi Otto,

apologies for a late reply.

In order to reset a workflow without opening it one can indeed export&reset and re-import or alternatively deploy to a server/Hub and reset before deployment. Then you can copy the workflow back to the local repository. Other hacks like tweaking the configuration file settings.xml of th corresponding node (if it is a single node that causes problems) can also do the job, but those are not supported.

I have to admit that I was not able to reproduce your problem. I have used 10x zoom and was able to save and reopen this workflow without problems:

Best regards,
Mischa

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.