Knime immediately shut down itself when I execute DL4J feedforward learner(classification).

Knime immediately shut down itself when I execute DL4J feedforward learner(classification). I have Mac OS Catalina. Same flow works in my windows computer. What should I do to solve this problem?
(I also uninstall and reinstall DL4J extension, but still same problem…)

Hi @Hikmet,

unfortunately there seems to be some bug causing this on Mac with the DL4J version we use in KNIME (which is pretty old). Currently, I’m not 100% sure what is causing this. We had a similar problem before which was related to some conflict created by Anaconda. You could try removing Anaconda if you have it installed.

Would it maybe possible for you to switch to our Keras Integration? It has the same (and many more) features compared to DL4J and should work fine on all OS.

Sorry for the inconvenience.

Cheers,
David

2 Likes

Thank you for the response.Yes, I have Anaconda but I work on it daily. Can I use Keras integration in Knime without removing Anaconda from my computer?

Hi,

yes, Keras should not interfere with other software on your machine. Generally, I would recommend to use Keras if possible when you want to do Deep Learning in KNIME. However, it requires a bit of setup as it is actaually base on Python (using Anaconda). You can find installation instructions here.

5 Likes

I installed Keras integration. While executing Keras network learning node following error showed up:
“ERROR Keras Network Learner 0:61 Execute failed: An error occurred while creating the Keras network from its layer specifications.
This could be due to a version mismatch between Keras and TensorFlow.
Please make sure that Keras 2.1.6 and TensorFlow 1.8.0 are installed in your Python environment.
See log for details.
You can install the correct version of Keras and TensorFlow on the ‘Python Deep Learning’ preference page.”

I have Keras 2.3.1. and Tensorflow 2.0.0 in Anaconda . Moreover, Anaconda don’t let me to pass previous versions of Keras and tensoflow as follows:

" UnsatisfiableError: The following specifications were found to be incompatible with the existing python installation in your environment:
Specifications:

  • keras==2.1.6 -> python[version=’>=2.7,<2.8.0a0|>=3.5,<3.6.0a0|>=3.6,<3.7.0a0’]

Your python: python=3.7

If python is on the left-most side of the chain, that’s the version you’ve asked for.When python appears to the right, that indicates that the thing on the left is somehow not available for the python version you are constrained to. Note that conda will not change your python version to a different minor version unless you explicitly specify that."

What should I do to overcome this problem?

Hi @Hikmet,

sorry for the late answer. The Keras Integration requires specific versions of Keras and Tensorflow to be installed (Tensorflow 2.0 is currently not supported). Did you install the required packages manually or did you use the auto setup feature on the Python Deep Learning preference page? We strongly recommend using the auto setup feature (Option 1 documented here) as this will automatically create a new Anaconda environment and install the correct versions. After that the Keras nodes should just work. During the setup you will have the choice to either create a CPU or GPU environment. Only use GPU if you are sure that you have a compatible GPU available. If not, chose CPU.

Cheers,
David

2 Likes