knime.in isn't recognize

Dear Community,

I use to work in a workflow that include R nodes, in particular R snippet or the combination of Table to R and R to Table. I always start the script with the command:

rframe <- knime.in

At the moment there is a single Table to R (all the others R node) are working perfectly) that doesn't recognize the command, the console give me this message:

> rframe <- knime.in
Error: object 'knime.in' not found 

The previous node is a Joiner and it is executed with no error; moreover the output table of the Joiner show me the data input for R node.

I tried to skip the previous joiner or to switch to R snippet node. The problem remains.

 

Please, should anybody help me?

Thanks, Claudia.

 

I would like to add some considerations rasing from new tests that I made.


It seems that the workspace of R node has not been loaded because of the large number of rows that I would like to process with R (through the input port). They are about 8 millions rows, with 20 columns. Trying to use a sampling table with only 100 rows as input, it works! It means that R node input has a size limit. Is there anyone that knows how to manage it?


I found a parameter in Knime preferences (R section). It is called "Rserve receiving buffer size limit (in MB)". I tried to double it but I didn't resolve the problem.
Is there anyone that knows if the parameter could be correlated with the size limit of R node's input?

Thanks in advance.

Bye bye.

Claudia

R is using only physical memory so you are limited only to it's size.