Knime Integration

I am trying to integrate my knime workflow in jupyter notebook and trying to run this part.

with knime.Workflow(workflow_path=workflow,workspace_path = workspace) as wf:
wf.data_table_inputs[0] = df
wf.execute()

However, I am running into some permission error and not 100% sure what is this error about. I already tried closing out from knime analytics plateform just to make sure my workflow is not open on knime while i run it in jupyter.

Here is the exact error I am receiving while running mentioned code:

PermissionError Traceback (most recent call last)
in
1 with knime.Workflow(workflow_path=workflow,workspace_path = workspace) as wf:
2 wf.data_table_inputs[0] = df
----> 3 wf.execute()

~\Anaconda3\lib\site-packages\knime.py in execute(self, live_passthru_stdout_stderr, output_as_pandas_dataframes)
409 ):
410 “Executes the KNIME workflow via KNIME’s batch executor.”
→ 411 outputs = run_workflow_using_multiple_service_tables(
412 self.data_table_inputs,
413 executable_path,

~\Anaconda3\lib\site-packages\knime.py in run_workflow_using_multiple_service_tables(input_datas, path_to_knime_executable, path_to_knime_workflow, input_service_table_node_ids, output_service_table_node_ids, save_after_execution, live_passthru_stdout_stderr, output_as_pandas_dataframes, input_json_filename_pattern, output_json_filename_pattern)
273 logging.info(f"knime invocation: {shell_command}")
274
→ 275 result = subprocess.run(
276 shell_command,
277 shell=True if os.name != “nt” else False,

~\Anaconda3\lib\subprocess.py in run(input, capture_output, timeout, check, *popenargs, **kwargs)
487 kwargs[‘stderr’] = PIPE
488
→ 489 with Popen(*popenargs, **kwargs) as process:
490 try:
491 stdout, stderr = process.communicate(input, timeout=timeout)

~\Anaconda3\lib\subprocess.py in init(self, args, bufsize, executable, stdin, stdout, stderr, preexec_fn, close_fds, shell, cwd, env, universal_newlines, startupinfo, creationflags, restore_signals, start_new_session, pass_fds, encoding, errors, text)
852 encoding=encoding, errors=errors)
853
→ 854 self._execute_child(args, executable, preexec_fn, close_fds,
855 pass_fds, cwd, env,
856 startupinfo, creationflags, shell,

~\Anaconda3\lib\subprocess.py in _execute_child(self, args, executable, preexec_fn, close_fds, pass_fds, cwd, env, startupinfo, creationflags, shell, p2cread, p2cwrite, c2pread, c2pwrite, errread, errwrite, unused_restore_signals, unused_start_new_session)
1305 # Start the process
1306 try:
→ 1307 hp, ht, pid, tid = _winapi.CreateProcess(executable, args,
1308 # no special security
1309 None, None,

PermissionError: [WinError 5] Access is denied

Can please anyone help me resolve this issue?