KNIME is not able to initialize the DL4J library (when the GPU option is enabled in KNIME).

Hi,

I am using knime-3.5.1 on RHEL 6.5 with Cuda 8.0 on a server with NVIDIA Tesla K20X GPU Accelerator.

After enabling GPU option in Deeplearning4J Integration from preferences and restarting it - I receive below set of errors when I try to initialize a  “DL4J Model Initializer” node from Deep Learning-DL4J-Layer

 

-------------------------------------------------------------------------------------------------------------------------------

The selected node could not be created due to the following reason:
Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject

-------------------------------------------------------------------------------------------------------------------------------

ERROR RepositoryManager               MetaNode alexnet' from plugin 'org.knime.ext.dl4j.base' could not be created: org/deeplearning4j/nn/api/Model
ERROR RepositoryManager               MetaNode deepmlp' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode lenet' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode simplemlp' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode deepbelief' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
-------------------------------------------------------------------------------------------------------------------------------

 

I have tried all the options of using different versions of jdk eg. jdk1.8, re-installing cuda & knime, changing Heap memory  etc but still these errors are the same all time.

 

I am also attaching the log-file.

 

Looking forward for possible help in resolving this issue- thanks.

 

 

 

Hi,

Can you try to increase the memory available to DL4J in File -> Preferences -> DeepLearning4J?

Best,

Christian

When I try to access preference at DL4J in File -> Preferences -> DeepLearning4J,

 

I receive this errors: 

Unable to create the selected preference page.

An error occurred while automatically activating bundle org.knime.ext.dl4j.libs(361).

---------------------------------------------------------------------------------------------------------------

However was able to change that value to maximum possible in new workspace - yet that didn't resolve this issue.

We'll investigate this further and come back to you as soon as possible. In the meantime, did you check https://www.knime.com/forum/knime-labs-general/dl4j-gpu-setting-error-messages-with-windows-10-64-g540m-knime35?

Thanks for the response.

 

I did check this post before posting my question -  In our case it doesn't seem to be a hardware issue as I have tried the same on windows platform with same hardware and it worked.

However, we need to run it on linux platform, will be waiting for your response.

 

Hi AKBERTHEROCK,

the root of the problem is following error:

Caused by: java.lang.RuntimeException: No CUDA devices were found in system

There seems to be a problem with the CUDA configuration on your system.

Did you try to run other CUDA applications? E.g. the CUDA examples or something in python that uses CUDA? Maybe there is something wrong. Depending on how familiar you are with python, I think it would be easiest to try to run the cuda examples (7.2.3. Verify the Installation).

If these do not work, then there is something wrong with your CUDA installation.

Cheers

David

Thanks for pointing out the issue. I will re-install CUDA and update you.