KNIME Labs QuickForm nodes not considered during QuickForm execution, default value cannot be changed in Metanode configuration


I'm trying to create an interactive workflow using QuickForm nodes. As the default Date (String) Input node does not offer a convenient date selection, I want to use the Date Input (Labs) node. However, the latter does not appear in the QuickForm Execution wizard.

Conversely, only the Labs QuickForm node appears in the Metanode configuration. However, any changes to the default are reverted/ignored.

I've attached a minimal working example (both nodes encapsulated in a meta node with two flow var iable outs). Thanks!


(I'm using KNIME 2.12)

The regular QuickForm nodes only work in conjunction with Metanodes, the new QuickForm nodes in labs only work with Subnodes. To use just choose collapse to Subnode from the context menu or alternatively you can also convert a Metanode to a Subnode from the context menu.

Please note that you will have to configure which flow variables get passed into the node and also are exported from the Subnode in the Virtual Input and Output nodes.

Hi all, and happy new year!


Working with KNIME 3.1, I was able to put the Legacy Input nodes into a Metanode and get them working (i.e. responding to user input), but the current (non-legacy) Quickforms nodes always take the default value. And there seem to be no subnodes available in 3.1.


Would you maybe have a small example workflow using the current Quickforms input nodes in KNIME 3.1?



And there seem to be no subnodes available in 3.1.

I wasn't aware of the option to wrap a metanode, as suggested in this post:

That solved it for me.


Same here!

Same problem here. The legacy Quickforms nodes work in a Metanode in QuickForm Execution mode but the QuickForm (not legacy) don't work in a Wrap node in QuickForm Execution mode.

Hi all, 

I am having the same issue, as per the attached workflow.

I created  A Wrapped Metanode with two Quickform date choosers. 

Double clicking on the Metanode brings up a dialog where I can enter the two date elements.


However trying to run the workflow using Quickform Exectution, it detects no quickforms in the workflow...


Thanks for any help in this regard. 



Hi Oburri,

I tried your workflow (only the entry part) and it shows the entry fields (Start and End date) on the server without any issue. You shouldn't execute the Workflow in Knime Analytic platform. Just execute it on the server.




I agree with @iiiaaa that it's quite confusing that the QuickForm Execution mode in the Analytics Platform is not working as expected, i.e. just the same as in the web portal. If it's an old legacy function from Knime v2, it should be disabled by default, so that new users don't get confused.




Dears Jan and Saad,

Thank you both for your replies. Just so I understand.

You have something called a Quickform Wizard which had a functionality that people were apparently using on KNIME Analytics Platform.

You updated Quickforms to a newer version that is compatible with KNIME Server but no longer with the Quickform Wizard.

And the solution that you are offering now is to update to KNIME Server in order to be able to have a dialog window pop up when running a pipeline with user interaction.

As far as I understand, KNIME Server is license based. So does that mean that the only way to run a workflow interactively using Quickforms is to buy a license?

Are there any other solutions within KNIME Analytics?

Kind regards