KNIME OJDBDC error in Command Line

Hi I’ve downloaded the latest java driver (ojdbc8) and have Knime 4.1.2 and have registered the driver with a valid connection. The worflow works perfectly in KNIME; however running it in command line mode, I get an error below. Any help would be greatly appreciated as I have Google this error and have not found a solution. Just need to the flow to run in batch mode and then I can schedule it in Windows. When I run the following command in command line batch mode

start “” “C:\Program Files\KNIME\knime.exe” -consolelog -nosplash -data “c:\temp\90DAYS_APPS.log” -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\Users\tariq.chaudhry\knime-workspace\90DAYS_APPS”

I get the following error

"…2020-03-12 11:33:31,764 : WARN : main : : ServerDBConnectorSettings : Oracle Connector : 0:1 : Due to restrictive licence terms we can not distribute the Oracle driver with the KNIME Analytics Platform.
You can download the latest driver at http://www.oracle.com/technetwork/database/application-development/jdbc/downloads/index.html
2020-03-12 11:33:31,767 : WARN : main : : UnauthenticatedServerDBConnectorSettings : Oracle Connector : 0:1 : To register the driver go to File->Preferences. In the preferences go to KNIME->Databases and register a new driver for the database type oracle by clicking on the Add button.
2020-03-12 11:33:31,769 : WARN : main : : Node : Oracle Connector : 0:1 : Please register a compatible driver via the KNIME preference page. (For details see the log file)

Thank you in advance.

Hi,

I’m solving similar issue here: Batch Mode - Oracle driver

Hi, you need to export your preferences from KNIME and use the filename in the command line with the -preferences switch, ie,/* the below worsk in command line */

start “” “C:\Program Files\KNIME\knime.exe” -consolelog -nosplash -data “c:\temp\90DAYS_APPS.log” -preferences=“c:\temp\Knime_Preferences.epf” -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“xxxx\knime-workspace\90DAYS_APPS”

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.