KNIME on Mac not working anymore (old Java 6-SE required)


Since approx. 1 week I'm not able to open KNIME anymore. I didn't change anything during this time. When I try to open KNIME, I receive this error message (please see attachment).

I reinstalled Java so far (but the newest - Java 8-Update 151). I installed all security updates for MacOS. But KNIME still doesn't want to launch.

I tried both versions for KNIME, the one before the current and the current available one: "KNIME 3.5.0".

Do you know, how I could solve this issue?


Thank you in advance

MacBook Air - macOS 10.13.2

Hi Wassermine,

we currently experience a problem on Mac and are working on a fix with high priority. In the meantime you can try to manipulate the knime.ini as follows:

Default in the Knime.ini there is an argument -vm ../Eclipse/plugins/org.knime.binary.jre.macosx.x86_64_1.8.0.152-01/jre/Home/bin

change that to

-vm ../Eclipse/plugins/org.knime.binary.jre.macosx.x86_64_1.8.0.152-01/jre/Home/lib/jli/libjli.dylib

Please let us know if this worked. Sorry for the trouble,


Hi Christian,

Great! This works perfect for me! Thanks for your fast and helping answer.