KNIME platform doesn't function after installing extensions

I downloaded KNIME platform on my laptop (Nov2020) and it worked fine, but yesterday after I installed a few chemistry-related Extensions (Lhasa, chemoinformatics, RDkit) KNIME won’t run, it shows me "a workflow coach loader error, I can’t access my older workflows, the welcome page won’t load either. It’s horrible!
I restarted KNIME, and uninstalled some of the extensions but it’s still not working.
The list of extensions won’t show the time there were installed, so it makes it hard for me to find those extensions that I installed recently.



Hi Max,

welcome to the KNIME forum!
I’m sorry to hear that you have trouble. Here are some suggestions you could try:

  • change your workspace (File > Switch Workspace > Other …); from there you can simply import your workflows from the original workspace (or copy them over)
  • uninstall all extensions or even use a fresh installation altogether

Could you also provide your knime.log? (e.g. accessible via View > Open KNIME log)



Hi Martin,

Thank you for your response and assistance. I followed your suggestions and the number of errors in log bar reduced from ~150 to something like 15.

Although I used KNIME only 4-5 times, I was unable to paste the Knime.log file here since the file is large (5,000 KB) and this forum couldn’t take it.

Here is an screenshot instead:

I copy-pasted the first few pages of the log file into a note file for your consideration:
KnimeLog short version.txt (68.3 KB)

Best wishes,
Max Sharifi, PhD

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.