KNIME prints missing value for a database column with content in it


I´m accessing a MS SQL Database with the DB Connector and DB Query Reader. Evrythink works fine, but for certain fields KNIME prints ? for Missing value, even though the database cell has a value present (confirment with different tools).
The database cell is a nvarchar 30 and the mapping in KNIME is String. Other columns with varchar 200 or something else are displayed. The problem occures with different columns, but I can’t seem a pattern.
I didn’t alter the input mapping.

Any ideas?

Best regards,


Hello @goodvirus and welcome to the KNIME Forum,

Could you please send us the configuration (input dialog), of the mapping part. Also screenshots of the problem may help us to find out what could be the problem.

All the best,


1 Like

For a case, you can check the driver you use to connect. If it is jTDS or Microsoft. jTDS my have issues.

Hello @josegallardo,

I´m not that new, but thanks for welcoming me again nevertheless :slight_smile:
Here are the configuration:
The DB-Connector Node -Connection Settings
(diffent Dialect makes no difference):

The DB-Connector Node -Input Mapping (all Default)

DB Query Reader - Input Type Mapping (all Default)

Even explicit Mapping to String makes no difference

The Querry and Result

DB Query Reader Result -Column Specs

The Query Azure Data Studio

I´m glad for any tipps you can give me,

Best regards,


@goodvirus have you considered excluding missings? And maybe add an ORDER statement where you put something like “ORDER BY xyz DESCENDING MISSINGS LAST” (might depend on your SQL dialect).

1 Like

Hi @mlauber71,

because there is just one row that is hit, when I exculude the missing values in the where clausel, I get no results. The order by statement (for MSSQL its “ORDER BY ISNULL(Serial, 1), Serial DESC”) makes no difference.

The funny thing is, that this problem is not consitant. Other columns (same data type) don’t have the same problem…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.