Knime Scheduling via Batch Mode – "reset" flag triggers application start and aborts workflow

I’ve come across a possible issue causing the batch mode to fail. While triggering Knime on a Windows 10 via the following command, the application get started but the workflow does not get executed. However, removing the -reset flag, everything works like a charm.

Documentation: https://www.knime.com/faq#q12

Command: knime.exe -nosplash -application -reset |org.knime.product.KNIME_BATCH_APPLICATION -workflowDir= `“workspace/Knime_project”

Hi @mw
The problem lies in the order of commands -application needs to be followed by org.knime.product.KNIME_BATCH_APPLICATION directly, you can not put -reset in between.

Try the following command line instead: knime.exe -nosplash -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir= “workspace/Knime_project”

best,
Gabriel

1 Like

Hi @gab1one,

assumed there was an order, thanks for your help. It works now as expected. Regarding the error screen which is noticed in the FAQ … while checking for examples I stumbled across this: https://github.com/stevenengland/KnimeNet

Another way to orchestrale Knime throuhg .Net. Maybe this provides some more options …

Thanks again
Mike

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.