KNIME sents no mail.

Hello,

I have a problem with the configuration of KNIME-Server-Mail.
I have edited the knime.xml towards the following:

Resource auth=“Container” mail.smtp.from=“NAME” mail.smtp.host=“smtp.ionos.de” mail.smtp.port=“587” mail.smtp.auth=“true” mail.smtp.user="NAME@NAME.de" password=“Test” mail.smtp.starttls.enable=“true”
name=“mail/knime” type=“javax.mail.Session”/>

But KNIME sents no E-Mail. Where is my mistake?

Hello @pm_hannover,

welcome to the KNIME community.

Except for the missing “<” in front of the Resource auth on the first line it looks good (assuming that the user and password are propery set). Is there any proxy involved in the communication? Are you able to send mails within workflows on the server using the “Send Email” node?

Best,
Michael

1 Like

Hey Michael,
thank you for support.
I am able to send mails via the E-Mail-Node with the same settings.
So something might be wrong in the code, I think…

Best,
Alex

Hey Alex,

this could be related to some security settings within your OpenJDK installation. The available TLS connection protocols could be restricted in the java.security file using the parameter jdk.tls.disabledAlgorithms. On a Linux system java.security is located in the OpenJDK install folder, e.g. /usr/lib/jvm/java-8-openjdk/jre/lib/security.

Please check, if the TLSv1 protocol is forbidden, as this is the default connection method of the KNIME server.

Best,
Michael

Hello @pm_hannover

Were you able to get this working?

I have the same problem with KNIME Server 4.12.0

Thanks,

KP

Hi @kamleshp,

I answered you in your other topic, please have a look at the possible solution there. I think you configured it in the wrong file, as the configuration option moved to the knime-server.config.

Cheers,
Michael