KNIME Server 4.4.0 Error while Executing Workflow

Hi,

I just installed the Server 4.4.0 from this site.

https://download.knime.org/server/4.4/4.4.0/knime-server-installer-4.4.0.jar

I have KNIME 3.3.2 as the Analytics Platform, KNIME Server RMI Slave 4.4.0.v201612012034 installed and KNIME ServerSpace 4.4.0.v201612012034 installed but still when I run the workflow it gives me the follwoing error:

"KNIME Slave 4.4.1 is not compatible with KNIME Server 4.4.0". I downgraded the Server RMI Slave from 4.4.1 to 4.4.0 and restarted the server ti does not help.

Not sure what I'm doing wrong here.Glad if anyone can help.

Thanks!

Regards,

Mohammed Ayub

Here is a snapshot for reference. No sure if these are causing any errors.

extensions.png

Hi Mohammed,

we would highly recommend the update to 4.4.1 in any case. We fixed some major problem with the.1 release.

You can find the update guide here: https://download.knime.org/server/4.4/KNIME_Server_Update_Guide_4.4.pdf

and the update files here: https://www.knime.org/knimecom-product-downloads-2016-12

Best, Iris

Sure. Let me give this a try.

Thanks !

Mohammed

Hi Iris,

I updated the server to 4.4.1 and thankfully resolved this error - "KNIME Slave 4.4.1 is not compatible with KNIME Server 4.4.0". I'm able to see the workflow and execute them on the WebPortal.

However I cannot add my server in the KNIME Explorer and login. It says login failed for the user. Attached is the snapshot for the same.

I have also updated KNIME suing File- > "Update KNIME". Attached snapshot for the extension currently installed (checked ones)

Let me know if I mssed something or screwed up any extensions.

Thanks !

Mohammed

extensions2.png

knime_login_error2.png

Hi Mohammed,

it seems there is an additional / after the localhost. your URL should be

http://localhost:8080/tomee/ejb

Best, Iris

Even before you add it, I wanted to test if the connection works fine, and It fails to connect

Sorry I should have sent you this snapshot. Attached is the screen shot.

Thanks

Regards,

Mohammed Ayub

knime_server_error.png

I tried adding the URL you gave. It still gives the error.

Regards,

Mohammed Ayub

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.