KNIME Server Executing a prior version of Workflow


I have a very puzzling and frustrating problem with execution on a remote KNIME Server for one specific workflow, which is a very large piece of work.

If I open up this workflow (remotely) and make changes to it, and then save my workflow to the server (it uploads back to the server), then the saving itself works fine. I can close the workflow and then re-open it and my workflow is updated for my changes - no problem up to this point.

However, when I then execute the workflow on the server, the server executes the previous version of the workflow (the one before I made the changes). I just cannot get it to run the current version, it's always one step behind.

I have even tried copying the workflow to my Local workspace, renaming it, placing it back onto the Server with the new name. Initially it works by running the current version again, but then as soon as I make a change, the behaviour (executing a previous workflow version) begins once again.

Has anyone seen this behaviour before or have any idea why this behaviour is happening?

Please note I am using KNIME Server Lite, so don't have the in-built KNIME versioning functionality of the full KNIME Server.

Just to confirm real quick: Is it possible that your workflow is running as a scheduled job? Since jobs are copies of a workflow at the time of first execution, later changes to the workflow would not affect an existing job.

If that is the case, you should be able to fix this by deleting the old jobs before starting with the new workflow. If not, please let me know so that we can take a closer look into this.



Hi Roland,

Thanks for your response. I can confirm that I am doing a right-click and execute directly on the workflow that's been updated. If I open the workflow, the updates/changes are all still there - but when I right-click and execute the same workflow in it's closed state, then it executes a previous version.

Very weird and I don't get the same behaviour on any other workflow.

Have you tried deleting any old jobs created by this workflow that might still be on the server? It is certainly weird that only this workflow is affected. If deleting old jobs doesn't help, would you mind sending me your workflow so that I can have a closer look?