KNIME Server Extensions - Problem installing extensions

extensions
#1

Hi All,

We’ve just recently deployed KNIME Server through an AWS Linux image.
Basic workflows run just fine, but we’re getting an error in Cell Splitter due to missing extensions.

KNIME_Server_Error

We have tried installing extensions following instructions:
https://docs.knime.com/2018-12/server_admin_guide/index.html#installing-additional-extensions

Haven’t been able to do it. Could anyone either:
A) Share experience on solving this issue
or
B) Referr us to any freelancer/company that has precise expertise with KNIME?

Thank you all

Best,
Walter

0 Likes

#2

Hi there,

Are you using an AWS Marketplace image? If so, can you post me a link to the image that you’re launching (Marketplace page). I’ll then be able to look into the issue myself and get back to you with more information.

Best,

Jon

0 Likes

#3

Hi Jon,

Thank your for the quick response.

Here it goes:
https://aws.amazon.com/marketplace/pp/B07JH2TGJV?qid=1557237671536&sr=0-2&ref_=srh_res_product_title

AWS AMI: ami-0885db09c10abd5dd

Does this work?

Best,
Walter

0 Likes

#4

Hi Walter,

Thanks for the message. We’re currently waiting for approval for a new version (4.8.2) to be published on the AWS Marketplace. I hope it will be online in a few days. That doesn’t help you now though. Could we schedule a call for tomorrow to make the fix on your current instance? Please drop me a DM with your availability.

Best,

Jon

0 Likes

#5

Hi Walter,

Just wanted to confirm, that with the current 4.7.3 AMI for KNIME Server Small from the AWS Marketplace, I launched an instance and tried to reproduce with a simple workflow that uses the Cell Splitter. I don’t see that problem. We have a call scheduled later this afternoon to dig into the issue a little deeper and see what is going on in your case.

Best,

Jon

0 Likes

#6

Hi Walter,

From our call we figured out that the workflow you tried to run was created with KNIME AP 3.7.x and the executor installed by default is 3.6.x. Since we’re waiting for approval of the new KNIME Server AMIs on AWS, we did an in-place upgrade of the KNIME Server and the executor. That solved your problem.

I also pointed you to our latest documentation specific to the AWS instances:
https://docs.knime.com/latest/aws_marketplace_server_guide/index.html

Best,

Jon

0 Likes