Knime Server Installation

I installed knime server and executor using Installer jar file as mentioned in Knime official docs. But Knime server failed.

● knime-server.service - KNIME Server
Loaded: loaded (/usr/local/lib/systemd/system/knime-server.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/knime-server.service.d
Active: failed (Result: exit-code) since Mon 2023-02-20 10:58:57 CET; 1h 47min ago

ses000581:/home/nbellig # systemctl status knime-executor.service
● knime-executor.service - KNIME Executor
Loaded: loaded (/usr/local/lib/systemd/system/knime-executor.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/knime-executor.service.d
Active: active (running) since Mon 2023-02-20 11:32:14 CET; 1h 15min ago
Main PID: 3087 (knime)
Tasks: 59
CGroup: /system.slice/knime-executor.service
├─3087 /srv/datavol/knime-executor/knime -nosplash -consolelog -data /home/knime/executor-workspace -profileLocation http://localhost:8080/kni>
└─3118 /srv/datavol/knime-full_4.6.3//plugins/org.knime.binary.jre.linux.x86_64_17.0.3.20220429/jre/bin/java -server -Dsun.java2d.d3d=f

Can anyone suggested me why server is failing ??


Hi @nehabellig,

The KNIME Server (Apache Tomcat) gets initially started once at the end of the installation process.
If you haven’t stopped it via <apache_install_folder>/bin/ or via kill -9 <pid> it will still be running in the background.
This will prevent the KNIME Server service to start as it will fail to assign the needed and configured
communication ports.

Could you try to stop a background KNIME Server process via executing <apache_install_folder>/bin/ first and check afterwards, if you are able to start the KNIME Server service via
sudo systemctl start knime-server


Hi @MichaelRespondek ,
Tried both ways using shutdown and also killing process and then starting the service. But it didnt work.
When i tried to start the service got this:
systemctl start knime-server.service
Job for knime-server.service failed because the control process exited with error code.
See “systemctl status knime-server.service” and “journalctl -xe” for details.

status is :
● knime-server.service - KNIME Server
Loaded: loaded (/usr/local/lib/systemd/system/knime-server.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/knime-server.service.d
Active: failed (Result: exit-code) since Tue 2023-02-21 06:40:52 CET; 19min ago
Process: 693 ExecStartPre=/bin/touch /var/run/ (code=exited, status=0/SUCCESS)
Process: 697 ExecStartPre=/bin/chown $USER /var/run/ (code=exited, status=0/SUCCESS)
Process: 698 ExecStart=/usr/local/libexec/knime-server/server start (code=exited, status=203/EXEC).

Is there any way we can get logs to figure out what is the issue ?

Thanks, Neha

We were able to solve this during a support call.
Root cause: The execute rights on one of the folders of /usr/local/libexec/knime-server/server were not granted for the executing user of the KNIME Server service.

Hi @MichaelRespondek ,
We are now able to login into webportal but while running the workflow we get error.
Couldnot create job gateway timeout. Any idea whats the issue ?
we are using rabbitmq , for it instead of default port 5672 we have changed it to 55672
and proxies are listed in knime.ini with values


Hi Neha,

Thank you for the provided update. Bad to hear that you are still facing issues.

Let’s take care of the proxy configuration:

Using the mentioned lines in the knime.ini will activate the proxy for all http and https connections without any exceptions. Therefore also the REST calls from the Executor to the KNIME Server to download a workflow for execution would be using the proxy and fail (triggering the gateway error).

You have to configure a proxy bypass list which is possible for http and https via


You should at least add the canonical address to the nonProxyHosts.

Alternatively you could try either to comment all the proxy configuration lines in the knime.ini out (to check wether it works in general) or follow up the preferred alternative configuration method below, for this you should also deactivate all proxy setting lines in the knime.ini:

If you are running the KNIME Executor under Windows (or Linux with X11 available) I would recommend to configure the Executor’s proxy via starting the knime.exe or knime with a dummy workspace and configure it via File → Preferences → General → Network Connections.

The proxy configuration will then stored under <executor_install_dir>/configuration/.settings/ and used even in the executor mode.

If you don’t have the possibility to run the executor in GUI mode (headless linux for instance) you can configure it on a local KNIME Analytics Platform and copy this file over to the KNIME Server machine.

I expect your issues being solved after the proxy setup is done.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.