KNIME Server Python Execution

Hi everyone,

I have a worfklow containing Python nodes. It successfully works on analytics platform, but when I run it on server, knime server (azure) returns a error code shown below.

ERROR Python Script 0:76:0:65: Execute failed: Could not start Python kernel. Error during Python installation test: Could not start Python executable at the given location (no_conda_environment_selected\python.exe): Cannot run program “no_conda_environment_selected\python.exe”: CreateProcess error=2, The system cannot find the file specified

For me, I have completed all Python integration steps on knime server. What is the reason of this error?

Any help would be appreciated,

Best,

-Kerem

Hi,

The Error message shows that the KNIME Executor tries to access the default dummy path, so your Python environmental settings are not used.

Could you please check, if the settings are done in the executor.epf file and not as in older KNIME Server versions (until version 4.10) usual in the preferences.epf?

You can also use additional client profiles if you link it afterwards in the knime.ini of the Executor.

Documentation: KNIME Server Administration Guide

Hope this helps,
Best,

Michael

Hi @MichaelRespondek,

Can I export preferences of my local analytics platform and import this preferences file into knime server? Will it works?

Best,

Yes, it will. Export the whole preferences of the KNIME Analytics Platform and add the lines regarding python to the executor.epf. You only have to change paths to met the servers Python environment.

Best,
Michael

Hi @KKERROXXX,

several weeks ago I had the same issue.

Solution was to edit the *.epf-file as follows:

org.knime.dl.python/pythonEnvironmentType=manual
org.knime.dl.python/manualConfig=/home/knime/anaconda3/envs/knime_dl_keras/bin/python
org.knime.dl.python/tf2ManualConfig=/home/knime/anaconda3/envs/knime_dl_tf2/bin/python

Best,
Sven

1 Like