Knime Server won't start NameNotFoundException / No Service registered for ServerConfig

Hi all,

First of all, I hope that you and your families are doing alright.

Now, I am having Knime Server and Knime Executor on the same machine (Windows), both the newest versions from the download site. I had installed them a couple of weeks ago, but after a restart, the server does not want to boot up. Tomcat is still firing up and I can access it via http://server-ip:8080.

It could be that there is something misconfigured, since a buddy of mine enabled SSL on the server. Sadly, he is not able to fix it either. Thus, help :smiley:

The error from the log:

18-May-2021 16:01:58.128 SEVERE [main] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class [com.knime.enterprise.server.pmml.models.PMMLScoringListener]

com.knime.enterprise.server.application.ApplicationContext$NoSuchServiceException: No service registered for com.knime.enterprise.server.config.ServerConfig

.

.

.

.

.

.

.

Caused by: javax.naming.NameNotFoundException: Name [com.knime.enterprise.server.config.ServerConfig] is not bound in this Context. Unable to find [com.knime.enterprise.server.config.ServerConfig].

I saw similar errors in the forum, but there wasn’t a solution to it - Unable to start Knime server - KNIME Server - KNIME Community Forum

Will be much thankful for a tip on where to search or even better, what to fix. Thanks in advance!

Cheers,
Nooby

Hi @nooby ,

Can you provide us with a few things for us to investigate further:

  1. KNIME server logs located under /logs
  2. knime-server.config file located in the / folder
  3. server.xml file located in the /conf/ folder
  4. The changes made to enable SSL and the settings before they were made if possible

Please email this to support@knime.com so that we can have the ticket in our ticketing system and we can communicate there and set up a call if necessary. We shouldn’t post these things in the public forum.

Thanks,
Zack

1 Like

Hi @ztrubow ,

Thank you for your reply and suggestion. However, I am not a fan of sharing the mentioned files. Thus, I still tried to find the error and fix it by myself. The simple “turn it off and on again” didn’t help.

→ Made backups of the workflows and SSL configuration, then purged the whole Knime installation (Server and Executor) and reinstalled them from scratch.

It seems like there was a misconfiguration somewhere.

Cheers to all, who tried to help. You can mark the thread as solved.

Regards,
Nooby

1 Like