Knime Server workflow POST resource always goes through proxy and fails

I have a workflow that calls a local rest service and returns json using a POST Resource node.  When I run it on the server, it always tries to go through our corporate proxy and fails.  It works fine if I run through Knime Analytics platform provided I have proxy settings set to "direct".

On my server, I have no proxy setting in my java or system variables.  I also removed all proxy settings from Windows (via IE) but it's still connecting through the proxy on my server.  I treid exporting my Knime Analytics Platform preferences and copying to <server-repository>/config but that made no difference.  

I even went so far as to write my own .war with a servlet that runs in TOMEE and  makes a URLConnection to my local rest service that succeeds (no proxy blockage) and returns my data.

My workflow run from the server is still trying to use my proxy and getting blocked.  Any suggestions??? Thanks!




Hi there,

Just wanted to check a couple of things.

1) You created the preferences.epf file from the analytics platform on the server, where you verified that the proxy settings were working.

2) When you exported the preferences.epf file it was named exactly that and added to the <server-repository>/config directory. You then restarted the apache-tomee service.



Yes Jon I did both of those.  

On Knime Analytics Platform, my workflow runs and returns my json result data with proxy set to direct.  Whenever I run the same workflow on the server though it ends up going through my proxy and fails.

I have exactly the same issue. We are running KNIME Server 4.4 on a Windows 2008 Server. If I run knime.exe from the executor folder my workflows run as expected however if I run the same workflow from webportal or scheduled then traffic is directed to the proxy and fails.

I have investigated JRE proxy settings and nothing seems to work.

Lookig for a solution to get this solved is now urgent