Knime under Mavericks

Hi all,


I upgraded my mac to Mavericks and having some issues with Knime.

After the upgrade, java was gone, so had to reinstall through the Oracle site. I downloaded the JDK version and installed it.

trying to start KNIME gives me the error that it needs the JRE 1.6SE

So I played around with my variables and did:

export JAVA=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home/jre/bin/java 

and now Knime starts, but gives me the following Warning:

The Java version currently active on your system (1.7.0_45) is known to cause problems and is not supported by KNIME under MacOS X. Please see for details and how to fix it.
Do you want to start KNIME anyway and continue on your own risk?

But I cannot find anything on this page about 1.7.0_45... Any help would be appreciated.



I thought KNIME bundled the JRE it needs anyway? 

Have you tried installing the Java 1.6 JRE? Old versions should be available on the oracle website.



Hi Geoffrey, 

We do not yet support KNIME on the mac under java 7.  I haven't checked this ina  few months, but there was a missing class which broke all of our dialogs.  How does KNIME under java 7 look for you?  When I updated to Mavericks I was prompted to download java 6 and after a couple of exta clicks, everything just worked.  Is unsetting your JAVA env and using Java 6 for hnow an option?

FWIW, we have tried to packaged the JRE in the .app, but ran into some technical problems with it. 

Regards, Aaron

KNIME just looks ok under Java 7. Ran some of the datamining examples without an issue. So I was worried for 'hidden' issues when the popup warnedme.

Maybe good to update the text on: because it states that Java 1.7 is a requirment (which made me think that it was just fine)....




Can you try to configure some dialogs and see if they behave properly?

Thanks a ton in advance. 

Regards, Aaron

Will try later tonight and include some screenshots

Unfortunately that does not work... Throwing the following error at me:


ERROR     NodeContainerEditPart     The dialog pane for node 'File Reader 2:12' has thrown a 'SWTError'. That is most likely an implementation error.

ERROR     NodeContainerEditPart     The dialog pane for node 'X-Partitioner 2:0:2' has thrown a 'SWTError'. That is most likely an implementation error.

I was able to click the install now button in the pop up and KNIME runs fine again now.... (using good old Java 6 JRE)



Yes, unfortunately that is what I expected.  This is a known issue that we may have to wait for java 8 in order to fix. 

Sorry for the hassle!

For those interested:

I spent too much time already on this so my head is spinning a bit (this being a waring about the maybe somwhat confusing post)

So I updated to Maverics too (couldn't wait :)

Now to the situation:

I have a eclipse_knime_2.8.1 installation (from before the update) where I imported our hcs-tools the scripting integrations and the knip nodes. When running it all in debug mode, there is no problem; knime starts up all the plugins are there, the log says hi.

However, I also pulled a new copy directly from our the repository (after the os update), created a new workspace and tried to run in debug mode again and then I get a lot of errors of this kind

ERROR     Thread-1 RepositoryManager     Node de.mpicbg.tds.knime.hcstools.preprocessing.OutlierRemovalFactory' from plugin 'de.mpicbg.tds.knime.hcstools' could not be created: Can't load factory class for node: de.mpicbg.tds.knime.hcstools.preprocessing.OutlierRemovalFactory The corresponding plugin bundle could not be activated!

... well pretty much for every node in the plugin.

So I tried the fix from the faq, only that this one does not really apply to a development environment.
I also set the 1.6 jdk in the preferences, included it in the manifest (execution environment) but this did not really help either.
I checked the logs (as suggested in one of the many other threads) and the only suspect thing was :

!MESSAGE Plug-in 'org.knime.workbench.ui' contributed an invalid Menu Extension (Path: 'view' is invalid): org.knime.workbench.ui.openLogfile

I am running out of clues. So my hope is that a more experienced eclipse user than me could point me in the right direction.
If you have any clue where to search for the bug I would be greateful.


The Eclipse log (.metadata/.log) should show you why your plug-in cannot be activated. This is usually because of missing dependencies or error when running the plug-in's activator (if it has any).

I posted the only suspect log entry from workspace/.metadata/.log, doesn't give me any useful information...

Did you look into the runtime workspace of the launched application and not your development workspace?

ok now we are on the same page I think.

There is a ClassNotfoundException for pretty much every <plugin>BuldleActivator. Funny thing is in the manifest, the Meta-mousover takes you to the BundleActivator class...

Aaron, in the thread you posted a link to there seems to be a solution for this issue now, since the release of java 7u40.
A minor change to the code is needed though.