KNIME update problem

Hi,

I'm currently with KNIME version 2.4.1. I'm trying to update to 2.4.2 but I get following error:

Cannot complete the install because of a conflicting dependency.
  Software being installed: KNIME Desktop Product 2.4.2.0030698 (org.knime.product.desktop 2.4.2.0030698)
  Software currently installed: Shared profile 1.0.0.1311852586917 (SharedProfile_KNIMEProfile 1.0.0.1311852586917)
  Only one of the following can be installed at once:
    KNIME Desktop Product 2.4.2.0030698 (org.knime.product.desktop 2.4.2.0030698)
    KNIME Desktop Product 2.4.1.0030383 (org.knime.product.desktop 2.4.1.0030383)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1311852586917 (SharedProfile_KNIMEProfile 1.0.0.1311852586917)
    To: org.knime.product.desktop [2.4.1.0030383]

What is the reason for that?

Regards

You are trying to update under a different user than the owner of the KNIME installation. Usually this happens if KNIME was installed with administrator rights e.g. because it is installed into Programs Files. Try running KNIME as administrator and then perform an update.

Hi thor,

This is strange, because I've just extract the exe into a Desktop without usual instalation and as far as I can remember I've never run KNIME as administrator even when install it. After that I was able to install extension pack and community contribututions pack. The latest case I tryed to update and failed and an hour later I installed CDK from nightly build repository.

You don't see any problems whan adding extension because a so-called shared profile is automatically created by Eclipse if it cannot write into the installation directory. Problems occur when you try to update because Eclipse cannot replace existing plug-ins in the read-only directory then. If you start KNIME as administrator and update everything should work fine.

Hi,

Starting update doesn't solve the problem. I still get the same error.

Regards

What do you mean by "starting update"? You need to start KNIME as administrator and then make an update from within this instance.

Hi thor,

I am sorry for my last post. It was in the middle of the night. I tried to start update as administrator and now I don't get this error. Thank you very much.

Regards