knime workflow running in a batch script doesn't finish

Hi,
I get stuck with the same problem of a batch never ending, although the workflow works, same problem as :


anyone has the solution ?
thank you
JM

Hi @jmderay
Do you by any chance use the -noexit commandline parameter, which is mentioned in https://www.knime.com/faq#q12 when you are using Windows?
I had the same issue, but I removed -noexit (and -consoleLog) from my batch file and after this Knime stopped when the workflow is finished.

4 Likes

hi Janduo
thank you for your reply but still the same …

Sorry it did not work for you.
Maybe one of the Knime team members can help, but they would need more background info like Knime version, your OS and the knime.log.

Thank you JanDuo finally it works well removing the 2 options -noexit and -consoleLog as you proposed (my try yesterday was probably bad …) So it’s all OK know, the workflow executes perfectly and knime stops at the end, we will add the .bat in a scheduled job with our automate
Thank you again !
Best

1 Like

Hi @jmderay

Great it worked afterall!

You can mark my post as solution, so others can see as well how the issue was solved (can help someone else in the future who is searching this forum for a similar issue).

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.