Links on Welcome to KNIME Analytics Platform! page not working

When I click on the links like “Creare new workflow” (URL: intro://newWorkflow/) I get
“The webpage cannot be displayed”. This error shows up for all internal links–ones that start with “intro://”. Any help on how to fix it?

Thnaks - DD

Hello DD,

I have seen this before when users are behind a firewall. If you are not able to “Get additional nodes” link to work then you may need to configure an HTTP proxy. Please check the FAQ https://www.knime.com/faq#usage_data, question “I cannot update/install additional extension or access the example workflow server because I am behind a firewall” to see if you have a firewall. I will also ask the team to see if there could be another problem.

What version of the KNIME Analytics Platform are you using?

Cheers,
Cynthia

I can download and/or update extensions, I just cannot open the link that have “intro:// …” in the URL. Such as “intro://newWorkflow/”. I think there is a broken link/mapping somewhere in the settings. I just don’t know where would it be.

I am using the latest version of KNIME Analytics Platform (3.6.1).

Hi DD,

I am checking internally with the team to see how we can fix this. I will keep you updated.

Cynthia

Hello DD - can you send me your KNIME.log file? This can be found
/.metadata/knime/knime.log

Thanks,
Cynthia

The log file is attached.

Thanks - Delenknime.log (2.6 MB)

One more log, please. If this is a UI error it will show under the Eclipse’s log. Can you please send me the log file? You can find it under the file /.metadata/.log.

Thanks

I uninstalled and then deleted all KNIME leftover folders, and reinstalled KNIME from scratch. Hoping that this would fix the error, well it did not, it is still giving me the same error. The screenshots are attached.

I created a new workspace so that the .log file would be clean, including only the link connection errors.

Thank you,

Delen

log.txt (1.9 KB)

That is certainly some odd behavior. As far as I understand, URIs with the intro scheme (intro://) are handled internally and not by a browser. Having said that, maybe switching the browser helps (File -> Preferences -> General -> Web Browser)?

In your knime.log, the only recent ERROR I noticed was the following “JS view set in preferences (org.knime.ext.seleniumdrivers.multios.ChromiumWizardNodeView) can’t be loaded. Switching to default.” That setting (found in File -> Preferences -> KNIME -> JavaScript Views) is only used for JavaScript-related nodes, so it should not be related to the issue you’re experiencing. But it is worthy of note that the error is also browser-related.

What happens when you right-click the “Create new workflow” link and press “Open” or “Open in new window”?

image

Hello @dursundelen,

Were the suggestions helpful or are you still having issues with the welcome page?

Thanks,
Cynthia

No, it did not work. I will reply to the responder again with my findings.

Having said that, maybe switching the browser helps (File -> Preferences -> General -> Web Browser)?

I tried this, it did not work. I get the same error.

What happens when you right-click the “Create new workflow” link and press “Open” or “Open in new window”?

Again, I get the same error.

** As I said before, and you commented on partially, the “intro://” is not triggering anything. It feels like it is not connected to anything. If it is part of the “*.ini” files somewhere, I can try to change/fix it. Any insight?

Delen

I believe it’s an issue with the default browser that is used to render the welcome page in KNIME. KNIME is using some standard browser of the OS (it’s some IE 11 library on Windows systems).

The browser is then told to handle different URL protocols differently. In this case it’s “intro://” that’s supposed to be handled by Eclipse/KNIME. The browser seems to ignore that request, which could be a security setting in the browser/OS or so.

I am speculating but it’s what I would guess after browsing the code for a little while. (I know this won’t be helpful but in case some people want to dig deeper: this is the code).

My suggestion: Use the shortcuts in the KNIME explorer to create new workflows or browse the examples.