"List Files" and "List Remote files" get different results

#1

Hello,

We have a Knime Server folder where some table files are saved automatically (output of a scheduled workflow). In the Server we can see two different files in that folder using a List Files node in a job. But we cannot see the same number of table files from a local KNIMSE Analytic Platform, when we use a List Remote Files node, with the same configuración (and using knime://knime-server path instead a knime://knime.mountpoint path). We only see one of those two files.

How this is possible??

0 Likes

#2

Could it be that list remote files includes directories while list files does not?

0 Likes

#3

No. Both files werein the same folder, and that folder was what we used in the configuration of both nodes.

0 Likes

#4

How are the files generated by the other workflow added to the server’s workflow repository? If you add them by simply writing to a file system location than it’s no surprise they don’t show up in the KNIME Explorer or in the output of a List Remote Files node. Direct access to the workflow repository on the server is highly discouraged as it may corrupt data structures. Access to the repository should always go via the REST interface. If you are using knime-URLs in your workflows (e.g. knime://knime.workflow/…) then this is done transparently. If you are using file URLs (file://) or file paths then please change your workflows to use the knime-protocol.

0 Likes

#5

The files are written using Table Writer node, as a result of a server runing job, and that node is configured with a knime://knime.mountpoint path.

0 Likes

#6

Hi @jricgar,

would it be possible for you to provide a minimal example to reproduce the issue?

To our knowledge there should be no difference in the listed files using those two methods. So we would be very interested to see the situation, in which it doesn’t happen. Unfortunately, we were not able to reproduce the issue that you see (also trying to play around with different permissions and different owners for the files that are listed)

Best regards,
Mischa.

0 Likes

#7

I’m not sure I can provide an usefull example. But I’m going to give you more details about the workflow that creates the file, and what happens after that:

  • Everyday, a server job lists the files in a server folder, using this node:

So we get every files that starts with “2M_alarmas”. After that, new calculations are done, and new proccesed data is stored in a new table, with a name that includes datetime. (e.g. 2M_alarmas_20190909T064522.table)

  • This table file is saved on server using this node:

  • This new table can be listed using a List Files in the same job, but from any KNIME Analytic Platform we cannot see that file (neither folder tree in KNIME Explurer View nor List Remote Files node).

  • After rebooting the server, the new table file appears everywhere.

Regards.

0 Likes

#8

Hi,

thanks for detailed reply. It included two additional useful pieces of information:

  • the files are also not visible in the KNIME Explorer
    – did you try the “refresh” button on top of the Explorer?
    – did you try to disconnect and reconnect to the server from the AP?
    – did you wait some time or did you look immediately after writing the files out?
  • rebooting the server makes files visible
    – do you mean reboot or just disconnecting and reconnecting again?

And for completeness, could you please tell your server and client versions for us to try to reproduce the issue in the same setup.

Best regards,
Mischa

2 Likes

#9
  • Refresh menu option doesn’t solve the problem. It doesn’t matter how long you wait.
  • Disconnect and re-connect to server doesn’t solve the problem. It doesn’t matter how long you wait.
  • So waiting doesn’t solve the problem.
  • Only server rebooting works.

KAP v3.7.2. KNIME Server 4.8.2.

Regards,

Raúl.

0 Likes

#10

Hi,

could you please try out on your server this workflow ? It will try to create a folder out in the server repository root directory (so you will need write permissions in the root directory) and then writes there 5 files: 4 files are written using the knime:// protocol (two using workflow relative and two using mountpoint relative path) and one using the absolute path (Node 13). Only the one that was written using the absolute path (out_direct.kntable) does not appear in the explorer and exhibits the behaviour that you have described.
2019-09-13_13h50_08
Could you try if you observe the same? If yes, will will have to hunt where there is a swap from mountpoint-relative to the absolute path definition.

I have tried it on Server 4.8.1 running 3.7.1 executor.

Cheers,
Mischa.

0 Likes

#11

Workflow works locally in KAP:

If I deploy and run it on server:

I can create workflows and workflow groups on server’s root folder, so I suppose I have write permissions.

Regards,

Raúl.

0 Likes

#12

From the screenshot it looks like creation of knime://knime.mountpoint/out failed. Could you try if you have rights to create in manually in GUI?

0 Likes

#13

I can create “out” folder manually in KAP GUI.

0 Likes

#14

Ok, good. Let’s leave the directory creation for later. Could you remove the Create Directory node and try to execute the workflow. Note, that you will need to adjust the workflow-relative pathes in Node 2 and in Node 11 as it expects that writer_rel372 lives together with the out folder in the repository root. You will also need to modify Node 13 adding the absolute path to the server workflow repository (i see that in the local execution in the first screenshot it did not work)

0 Likes

#15

Hello Mischa,

My fault. I modify “Output Location” config of Node13 to: knime://knime-server/out/out_direct.kntable. Obviously it will work only in local KAP, as server doesnt accept remote routes.

So locally everything works:

Also I have deployed writer_rel372 to server root to avoid pathes modification on server.

But in anycase:

image

What’s happening??

0 Likes