List Remote Files node, "channel is not opened"

Dear Knime,

I noticed that the List Remote Files node throws an error message such as “execution failed: channel is not opened”. It has to do with going recursively into subfolders and happens if the subfolder has a “#” in the folder name.

If you just list the folders and don’t go into them recursively it will work and give you the list of subfolders. There you can see that the “#” is replaced by “%” in the folder name.

Knime version 4.1.0

Just wanted to let you know,


Hello Christoph,

You can use the URL to File Path (Variable) node, this way the path from the list will be converted to the initial one containing “#” and the file can be read successfully.


1 Like

Hello Christoph, hello Nick,

thanks for the feedback and workaround. The # is a reserved character in the URI-notation used for fragments. So it has to be escaped in the URI. I will forward your comments to our developers to have a look at the hash mark handling in this node.


1 Like

Hi @ChSager,

I can’t seem to reproduce the issue locally. In my KNIME 4.1, if I configure my Liste Remote Files node to recursively go into subfolders all of which contain hash tags, it escapes all the hash tags properly:

I have attached the (self-contained) workflow I’ve been using.

list_remote_files.knwf (4.4 KB)

What am I missing?




Hi @marc-bux, Thank you for your time. I tested your workflow and it works on my side.

My other workflow is still not working atm. I log into the server, go to /scratch/sagerch1 as the directory in the List Remote Files node, then Include sub folders yes, and look for file extensions “log”, however also “none” gives the same error as stated.

The folders, which are in /scratch/sagerch1 are these:

drwxr-xr-x. 2 sagerch1 sagerch1 4096 24. Feb 08:59 ChemExternalTool_976_2991752637287231127#chaluw-dev16-0-5e5380ff
-rw-rw-r--. 1 sagerch1 sagerch1  142 29. Jan 14:56 redir.html

The only thing I see here is the # which looks out of place, this is why I reported. Inside ChemExternalTool_976_2991752637287231127#chaluw-dev16-0-5e5380ff are a bunch of files related to a job run by Schrodinger Jaguar node. No further subdirectories, some symlinks to files within the same directory, all files are readable. If the hastag is not the problem, it seems one of the files in that folder is the problem?

Just let me know, if you want we can further look into this. However I do have a workaround in place and I think it would take a lot of effort in finding the cause to this problem.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.