"Local file browser configuration" node bug

Dear Knimers,

To me it looks like the “Local file browser configuration” cannot handle being in an inactive branch.

Example. This works:

…but when i make the upper branch inactive the workflow no longer works, because somehow the component is not made inactive:

When I replace the “local file browser configuration” node inside the component by a “string configuration” node the problem disappears as the full upper branch is now inactive, as it should be:

I attached the workflow. I am using KNIME 4.7.2 on Ubuntu 22.04.

Best,
Aswin
KNIME_project11.knwf (99.8 KB)

1 Like

Hi Aswin,

thanks for supplying this amazing example.

KNIME has two stages in which nodes are run: configuration and execution (yellow and green traffic light). I assume the issue here is that the configuration is run, even though the component is part of a disabled branch (and the configuration of the Local File Browser happens to fail).

I’ll pass this on to development to clarify whether this may be a bug or can be improved (while ensuring backwards compatibility), but for the time being, I believe you can work around this issue by connecting the nodes within the component to the disabled component input like so:

(Personally, I recommend always connecting nodes to the Component input. It feels a bit clearer to me when what node is executed or reset.)

Kind regards
Marvin

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.