Lost R home

Hi,

I have lost my R home unexpectedly. So I tried to fill it again in the Knime preferences. If I point the directory :

C:\Program Files\KNIME_2.10.4\plugins\org.knime.ext.r3.bin.win32.x86_3.0.3.0044664\R-Inst

It returns R_HOME does not contain an R executable.

So inside there is a bin directory. If I point on it

C:\Program Files\KNIME_2.10.4\plugins\org.knime.ext.r3.bin.win32.x86_3.0.3.0044664\R-Inst\bin

it returns : R_HOME does not contain a folder with the name 'bin'.

Has anybody an idea to retreave the R preferences path without reinstalling ?

Restore Defaults gives nothing : empty with the Error R_HOME does not exist.

Best regards

Fabien

Hi Fabien,

I just saw your Post, did you find a way to resolve the problem? Otherwise I will check with our R expert :)

Cheers, iris

Hi Fabienc, 

 

this problem is solved by giving preference R restore default or copying this path "C: \ Program Files \ KNIME_2.11.3 \ plugins \ org.knime.ext.r3.bin.win32.x86_3.0.3.0044664 \ R -inst " keep in mind that the path may vary according to the KNIME version you have.

Also try putting the local path of R from your computer, such as C: \ Program Files \ R \ R- 3.0.3
Bear in mind that the path may change according to the version of the R and the installation folder where you are.

I hope it helps you.

 

Hi

I'm having the same issue.

I was working with R in Knime yesterday and today is not working anymore, giving me a message"R Home is invalid."

I didn't change any settings..

Why is this happing?

 

Rather an old one Iris ;o) but thank you for your reply. Yes I solved it.