Match ANY of the following and ALL of the following working wrong way round?

I’m matching RowID of one table with two different columns on another table. I want a match if either column matches with RowID. If I choose “Match all of the following” I get matches, but if I choose “Match ANY of the following”, the node creates an empty data table.

Shouldn’t this work exactly the opposite way?

Hi Jouni, you’re right that if you want either column to match, selecting “Match any of the following” is the right way to go about it. I wasn’t able to recreate your issue and uploaded an example where it works for me. One thing to be aware of is the data types itself (I see that you have the created by and issued by IDs as integers and your row IDs might be strings). If the issue persists, you can send some sample data where this happens and I can investigate it further :slight_smile:
forum_joinanyall.knar.knwf (12.2 KB)

I dont see how data type should affect it since it still finds matches.

I have attached the sample data with the error.
test.knar.knwf (48.9 KB)

The problem was using the rowID. When I changed the Excel reader to generate the row ID and changed the joiner to correspond the change, it worked normally.

Something weird with using RowId then.

Ahh, that’s strange! The comparison with the RowID works fine if you convert the integers to strings, so I do think it’s a data type issue, but you’re totally right that it’s weird you get a joined table when selecting match all… I’ll try and find out why this happens, but in the mean time I would suggest always comparing row IDs to strings (as has been done here)
test.knar.knwf (56.9 KB)

Turns out you found a bug! Reported the issue to the developers :slight_smile:

3 Likes

And they fixed it! Should work properly in the next release, big thanks for pointing it out :smile:

2 Likes