Meta Node Within Loop

I'm running knime 2.5.2. I discovered that execution of my workflow will stop and hold in the "queued" state once it reaches a counting loop that contains a meta node. The loop will run fine without a hitch if the meta node is expanded, i.e. nodes within the meta node are placed outside and the meta node is removed. However, since my workflow is quite bulky, things can get very messy very fast without meta nodes.

I noticed a few instances of these two errors in my console just before execution stops at the problem loops:



WARN WorkflowManager Unable to merge flow object stacks: Stack can't be merged: Conflicting FlowObjects:org.knime.core.node.workflow.FlowLoopContext@36b2d04e vs. org.knime.core.node.workflow.FlowLoopContext@2109df79
WARN WorkflowManager Unable to merge flow object stacks: Stack can't be merged: Conflicting FlowObjects:org.knime.core.node.workflow.FlowLoopContext@2109df79 vs. org.knime.core.node.workflow.FlowLoopContext@36b2d04e

I attached a sample workflow. The loop is in the "models" meta node, then "A_B," then "One Layer." The meta node within the loop is called "Numeric Classifiers."

I have noticed the exact same problem too!


Yes, I have encountered this exact problem too, just yesterday.

Had this as well, are KNIME guys working on it? Would like to use filtering rows node in my loop but can not do it because of this error...

Sorry for late response. We must have missed this post. We can reproduce the problem with the attached workflow but need to break it down to "debuggable" pieces. We are working on it.


Dear all (in particular nebula828):

We believe(!) we could identify the problem and have fixed it. The problem seems to be the side branch in the loop, which contains a non-executable/failing CSV writer. We don't think it is related to meta nodes etc (there is some race condition involved; it depends on which node gets executed first: the side branch node or the loop end). One very simple workflow that replicates the problem is attached (which is now also part of the testing suite).

Can you check whether that workflow is similar to yours and shows the same behavior you are encountering? If in doubt we can also make a nightly build available to you to test whether that fixes your problem.


Hi All,

related to topic “Loop does not continue with looping”

it seems that knime doesn’t like dead code in a meta node in a loop

i slightly altered the flow

this one works

this one doesn’t

would be great to see this solved, because i was in the middle of refactoring a flow, so i didnt want to throw away old version code before having anything workable.



1 Like